welcome

The Keysight IO Libraries Suite software is provided on the Keysight Automation Ready CD-ROM provided with your instrument. Installation instructions are provided on the CD-ROM.

You can also download the Keysight IO Libraries Suite software, along with IVI-COM and LABview drivers from the Keysight Developer Network at adn.tm.Keysight.com.

The Keysight 34450A Programmer's Reference is provided as a Windows® Compiled Help (.chm) file on the Keysight 34450A Product Reference CD-ROM shipped with your instrument.

In addition, the following documents are available in Adobe® PDF format on this CD-ROM. (Requires Adobe Reader.)

  • Keysight 34450A Quick Start Tutorial

  • Keysight 34450A User Guide

You can also download these documents from the Web at www.Keysight.com.

For information about connecting instruments to USB and how to configure and troubleshoot an interface, refer to the Keysight USB/LAN/GPIB Interfaces Connectivity Guide. This guide is provided on the Keysight Automation Ready CD-ROM. Or you can download the guide from the Web at www.Keysight.com/find/connectivity.

We have included several example programs on the Keysight 34450A Product Reference CD-ROM shipped with your instrument.

To install the programming examples, see the Product Reference CD-ROM.

You can contact Keysight Technologies at one of the following telephone numbers for warranty, service, or technical support information.

In the United States: (800) 829-4444

In Europe: 31 20 547 2111

In Japan: 0120-421-345

Or use our Web link for information on contacting Keysight worldwide.

www.Keysight.com/find/assist

Or contact your Keysight Technologies Representative.

Keysight 34450A 5½ Digit Multimeter

Programmer's Reference

This Help file contains reference information to help you program the Keysight 34450A over a remote interface using the SCPI programming language. To determine the USB address of the multimeter, use Keysight Connection Expert available on the Keysight Automation Ready CD-ROM provided with your instrument. Installation instructions are provided on the CD-ROM.

Introduction to the SCPI Language

Commands by Subsystem

Commands A-Z

Command Quick Reference

SCPI Error Messages

Power-On and Reset State

Related Information

IO Libraries and Instrument Drivers

Keysight 34450A Documentation

Contact Keysight Technologies

Copyright © 2013–2015 Keysight Technologies

Help Version 1.3, August 21, 2015


Introduction to SCPI Language

Introduction to the SCPI Language

SCPI (Standard Commands for Programmable Instruments) is an ASCII-based instrument command language designed for test and measurement instruments. SCPI commands are based on a hierarchical structure, also known as a tree system. In this system, associated commands are grouped together under a common node or root, thus forming subsystems. A portion of the SENSe subsystem is shown below to illustrate the tree system.

SENSe:
VOLTage:
DC:RANGe {<range>|MIN|MAX|DEF}
DC:RANGe? [MIN|MAX]

SENSe is the root keyword of the command, VOLTage and RESistance are second-level keywords. A colon ( : ) separates a command keyword from a lower-level keyword.

Syntax Conventions

The format used to show commands is illustrated below:

VOLTage:DC:RANGe {<range>|MIN|MAX|DEF}

The command syntax shows most commands (and some parameters) as a mixture of upper- and lower-case letters. The upper-case letters indicate the abbreviated spelling for the command. For shorter program lines, you can send the abbreviated form. For better program readability, you can send the long form.

For example, in the above syntax statement, VOLT and VOLTAGE are both acceptable forms. You can use upper- or lower-case letters. Therefore, VOLTAGE, volt, and Volt are all acceptable. Other forms, such as VOL and VOLTAG, are not valid and will generate an error.

  • Braces ( { } ) enclose the parameter choices for a given command string. The braces are not sent with the command string.

  • A vertical bar ( | ) separates multiple parameter choices for a given command string. For example, {<range>|MIN|MAX|DEF} in the above command indicates that you can specify a numeric range parameter, or "MIN", "MAX", or "DEF". The bar is not sent with the command string.

  • Triangle brackets ( < > ) indicate that you must specify a value for the enclosed parameter. For example, the above syntax statement shows the <range> parameter enclosed in triangle brackets. The brackets are not sent with the command string. You must specify a value for the parameter (for example "VOLT:DC:RANG 10") unless you select one of the other options shown in the syntax (for example "VOLT:DC:RANG MIN").

  • Some parameters are enclosed in square brackets ( [ ] ). This indicates that the parameter is optional and can be omitted. The brackets are not sent with the command string. If you do not specify a value for an optional parameter, the instrument chooses a default value.

Command Separators

A colon ( : ) is used to separate a command keyword from a lower-level keyword. You must insert a blank space to separate a parameter from a command keyword. If a command requires more than one parameter, you must separate adjacent parameters using a comma as shown below:

CONF:VOLT:DC 10,3.0E-05

A semicolon ( ; ) is used to separate commands within the same subsystem, and can also minimize typing. For example, sending the following command string:

CALCULATE:FUNC DB; FUNC?

... is the same as sending the following two commands:

CALCULATE:FUNC DB
CALCULATE:FUNC?

Use a colon and a semicolon to link commands from different subsystems. For example, in the following command string, an error is generated if you do not use both the colon and semicolon:

CONF:VOLT:DC;:INIT;:FETC?

Using the MIN, MAX, and DEF Parameters

For many commands, you can substitute "MIN" or "MAX" in place of a parameter. In some cases you may also substitute "DEF". For example, consider the following command:

VOLTage:DC:RANGe {<range>|MIN|MAX|DEF}

Instead of selecting a specific value for the <range> parameter, you can substitute MIN to set the range to its minimum value, MAX to set the range to its maximum value, or DEF to set the range to its default value.

Querying Parameter Settings

You can query the current value of most parameters by adding a question mark ( ? ) to the command. For example, the following command sets the beeper to ON :

SYStem:BEEPer:STATe ON

You can then query the beeper state by sending:

SYStem:BEEPer:STATe?

SCPI Command Terminators

A command string sent to the instrument must terminate with a <new line> (<NL>) character. The IEEE-488 EOI (End-Or-Identify) message is interpreted as a <NL> character and can be used to terminate a command string in place of a <NL> character. A <carriage return> followed by a <NL> is also accepted. Command string termination will always reset the current SCPI command path to the root level.

IEEE-488.2 Common Commands

The IEEE-488.2 standard defines a set of common commands that perform functions such as reset, self-test, and status operations. Common commands always begin with an asterisk ( * ), are three characters in length, and may include one or more parameters. The command keyword is separated from the first parameter by a blank space. Use a semicolon ( ; ) to separate multiple commands as shown below:

*RST; *CLS; *ESE 32; *OPC?

SCPI Parameter Types

The SCPI language defines several data formats to be used in program messages and response messages.

Numeric Parameters

Commands that require numeric parameters will accept all commonly used decimal representations of numbers including optional signs, decimal points, and scientific notation. Special values for numeric parameters such as MIN, MAX, and DEF are also accepted. You can also send engineering unit suffixes with numeric parameters (e.g., M, k, m, or u). If a command accepts only certain specific values, the instrument will automatically round the input numeric parameters to the accepted values. The following command requires a numeric parameter for the range value:

VOLTage:DC:RANGe {<range>|MIN|MAX|DEF}

Because the SCPI parser is case-insensitive, there is some confusion over the letter "M" (or "m"). For your convenience, the instrument interprets "mV" (or "MV") as millivolts, but "MHZ" (or "mhz") as megahertz. Likewise "MΩ" (or "mΩ") is interpreted as megohms. You can use the prefix "MA" for mega. For example, "MAV" is interpreted as megavolts.

Discrete Parameters

Discrete parameters are used to program settings that have a limited number of values (like IMMediate, EXTernal, or BUS). They have a short form and a long form just like command keywords. You can mix upper- and lower-case letters. Query responses will always return the short form in all upper-case letters. The following command requires a discrete parameters for the temperature units:

UNIT:TEMPerature {C|F}

Boolean Parameters

Boolean parameters represent a single binary condition that is either true or false. For a false condition, the instrument will accept "OFF" or "0". For a true condition, the instrument will accept "ON" or "1". When you query a boolean setting, the instrument will always return "0" or "1". The following command requires a boolean parameter:

SYSTem:BEEPer:ENABle {OFF|0|ON|1}

ASCII String Parameters

ASCII string parameters can contain virtually any set of ASCII characters. A quoted ASCII string parameter must begin and end with matching quotes; either with a single quote or a double quote. You can include the quote delimiter as part of the string by typing it twice without any characters in between. The following command uses a quoted ASCII string parameter:

FUNC <quoted ASCII string>

For example, the following commands select the AC voltage function (double or single quotes are allowed).

FUNC "VOLT:AC" or FUNC 'VOLT:AC'

An unquoted ASCII string parameter does not use quotation marks. The following command uses an unquoted ASCII string parameter:

CALibration:SECure:CODE <unquoted ASCII string>

For example, the following command uses an unquoted ASCII string to set a new calibration security code (calibration memory must be unsecured):

CAL:SEC:CODE T3ST_DUT165

Using Device Clear

Device Clear is an IEEE-488 low-level bus message that you can use to return the instrument to a responsive state. Different programming languages and IEEE-488 interface cards provide access to this capability through their own unique commands. The status registers, the error queue, and all configuration states are left unchanged when a Device Clear message is received.

Device Clear performs the following actions:

  • If a measurement is in progress, it is aborted.

  • The instrument returns to the trigger "idle" state.

  • The instrument's input and output buffers are cleared.

  • The instrument is prepared to accept a new command string.

The ABORt command is the recommended method to terminate a measurement.


Commands by Subsystem

Other Commands

CALCulate Subsystem

CALibration Subsystem

CONFigure Subsystem

DATA Subsystem

DISPlay Subsystem

FETCh Subsystem

FORMat Subsystem

IEEE-488.2 Common Commands

MEASure Subsystem

MEMory Subsystem

SAMPle Subsystem

SENSe Subsystem

STATus Subsystem

SYSTem Subsystem

TRIGger Subsystem


ABORt

Syntax | Description | Remarks | Example

Syntax

ABORt

Description

This command aborts a measurement in progress.

Remarks

  • The command will abort a measurement in progress and stop, returning the instrument to the trigger idle state.

  • This command may be useful to abort a measurement when the instruments is waiting for a trigger.

  • The *RST command will abort a measurement and set all measurement parameters to their factory settings.

Example

The following command aborts the measurement in progress.

ABOR

See Also

*RST


INITiate[:IMMediate]

Syntax | Description | Remarks | Example

Syntax

INITiate[:IMMediate]

Description

This command changes the state of the triggering system from the "idle" state to the "wait-for-trigger" state. Measurements will begin when the specified trigger conditions are satisfied following the receipt of the INITiate command. Note that the INITiate command also clears the previous reading from memory.

Remarks

  • To retrieve the reading, use the FETCh? command.

  • The ABORt command may be used to return to idle.

  • The INITiate command only initiates the measurement and needs a trigger (BUS, IMMediate or EXTernal) to make the actual measurement.

Example

The following program segment shows how to use the INITiate command with the CONFigure and FETCh? commands. The INITiate command places the instrument in the "wait-for-trigger" state which is set to immediate. The FETCh? command transfers the reading from memory to the instrument's output buffer.

CONF:VOLT:DC 10,3.0e-5
TRIG:SOUR IMM
INIT
FETC?

Typical Response: +4.27150000E-03

See Also

FETCh?

READ?

ABORt


READ?

Syntax | Description | Remarks | Return Format | Examples

Syntax

READ?

Description

This command changes the instrument's triggering system from the "idle" state to the "wait-for-trigger" state. Measurements will begin when the specified trigger conditions are satisfied following the receipt of the READ? command. The reading is then sent immediately to volatile memory and the instrument's output buffer.

Remarks

  • By default, READ? only returns reading for primary function. If secondary function is set to ON, READ? will return readings for both primary and secondary function.
  • Sending the READ? command is similar to sending the INITiate command followed immediately by the FETCh? Command.
  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Return Format

The command sends readings directly to reading memory and the instrument's output buffer.

Examples

The following program segment shows how to use the READ? command to make a DC voltage measurement. The CONFigure command configures the instrument for a DC voltage measurement and sets the trigger source to IMMediate. The READ? command places the instrument in the "wait-for-trigger" state, initiates a trigger, and then sends the reading to the output buffer.

CONF:VOLT:DC
READ?

Typical Response: +1.26360000E-02

See Also

FETCh?

INITiate[:IMMediate]


UNIT:TEMPerature

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

UNIT:TEMPerature <units>

UNIT:TEMPerature?

Description

This command selects the units (°C or °F) to be used for temperature measurements.

Parameters

Name | Type | Range of Values | Default Value
<units> | Discrete | {C|CEL|F|FAR} | Required parameter.

Remarks

  • The command also accepts "CEL" or "FAR" for the units parameter, but the query returns "C" or "F".

  • The temperature unit selection is stored in non-volatile memory. The selection does not change after a Factory Reset (*RST command).

Return Format

The query command returns "C" or "F".

Examples

The following command sets the temperature units to °F.

UNIT:TEMP F

The following query returns the temperature unit selected.

UNIT:TEMP?

Typical Response: F

See Also

CONFigure[PRIMary]:TEMPerature

MEASure:[PRIMary:]TEMPerature?


CALCulate Subsystem Introduction

The Keysight 34450A can perform several mathematical, statistical, and limit calculation functions using the CALCulate commands.

Command Summary

Select and Enable Functions

CALCulate:FUNCtion

CALCulate:FUNCtion ?

CALCulate:STATe

CALCulate:STATe?

Limit Functions

CALCulate:LIMit:LOWer

CALCulate:LIMit:LOWer?

CALCulate:LIMit:UPPer

CALCulate:LIMit:UPPer?

Mathematical Functions

CALCulate:AVERage:AVERage?

CALCulate:AVERage:COUNt?

CALCulate:AVERage:MAXimum?

CALCulate:AVERage:MINimum?

CALCulate:DB:REFerence

CALCulate:DB:REFerence?

CALCulate:DBM:REFerence

CALCulate:DBM:REFerence?

CALCulate:NULL:OFFSet

CALCulate:NULL:OFFSet?


CALCulate:FUNCtion

Syntax | Description | Remarks | Return Format | Examples

Syntax

CALCulate:FUNCtion {NULL|DB|DBM|LIMit|AVERage|HOLD}

CALCulate:FUNCtion?

Description

This command selects the calculation function to be used. The default function is NULL.

Remarks

  • The CALCulate subsystem (math operations) must be enabled using the CALCulate:STATe command.

  • The instrument clears the calculation function selection, reverting to the default after a Factory Reset (*RST command) .

  • NULL equation: Result = Reading – Offset
    Set the Offset using the CALCulate:NULL:OFFSet command

  • dBm equation: Result = 10 x Log10 [ Reading2 / RREF / 0.001W ]
    Set the reference resistance (RREF) with the CALCulate:DBM:REFerence command.

  • When enabled, the dB operation computes the dBm value for the next reading, stores the dBm result into the dB Ref register and immediately produces the following calculation. The first computed reading is always precisely 000.00 dB.

    Result = 10 x Log10 [ Reading2 / RREF / 0.001W ] – dB Ref
    Set the reference resistance (RREF) with the CALCulate:DB:REFerence command.

  • LIMit: Compares each reading against upper and lower limits. Limit failures are posted in the Questionable Status Register.
    Set the upper and lower limits with CALCulate:LIMit:UPPer and CALCulate:LIMit:LOWer, respectively. Check for limit failures with the STATus:QUEStionable[:EVENt]? command.

  • AVERage: Returns the mathematical average of all readings taken since averaging was enabled.
    Use     CALCulate:AVERage:AVERage?, CALCulate:AVERage:MAXimum?, CALCulate:AVERage:MINimum?, and CALCulate:AVERage:COUNt? to return the average, maximum, minimum and count, respectively, since averaging was enabled.

  • HOLD: The reading hold feature allows you to capture and hold a stable reading (refer to the Keysight 34450A User's Guide for details).
    This feature only support measurement resolution 2.00E-5 and 1.50E-6.

  • The calculation function does not support external triggering.

  • When the secondary measurement function is enabled, the calculation function applies to the primary measurement only.

Return Format

The query returns the currently selected function: NULL, DB, DBM, AVER, HOLD or LIM.

Examples

The following command sequence sets the function to be calculated to DBM.

CALC:FUNC DBM
CALC:STAT ON
CALC:DBM:REF 16

The following query returns the currently enabled calculation function.

CALC:FUNC?

Typical Response: DBM

See Also

CALCulate:STATe


CALCulate:STATe

Syntax | Description | Remarks | Return Format | Examples

Syntax

CALCulate[:STATe] {OFF|ON}

CALCulate[:STATe]?

Description

This command turns the CALCulate subsystem, and thus the selected calculation function, on or off.

Remarks

  • The calculation function to be used is selected using the CALCulate:FUNCtion command.

  • CALCulate:STATe is set to OFF when the measurement function is changed.

  • When CALCulate:STATe:ON is sent the math registers for limits, statistics, and dB reference value and the value set by CALCulate:NULL:OFFSET are cleared. This also occurs when CALCulate:FUNCtion is sent with CALCulate:STATe previously set to ON. Note that the dBm reference resistance value is not cleared in either case.

  • The instrument resets the calculation state to off after a Factory Reset (*RST command) or a function change.

  • When CALCulate:STATe is set to ON, the secondary measurement function will be disabled.

Return Format

The query returns the current calculation state: "0" (OFF) or "1" (ON).

Examples

The following command sets the calculation state to "ON".

CALC:STAT ON

The following query returns the current calculation state.

CALC:STAT?

Typical Response: "1"

See Also

CALCulate:FUNCtion

CALCulate:NULL:OFFSET


CALCulate:LIMit:LOWer

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALCulate:LIMit:LOWer {<value> | MINimum | MAXimum}

CALCulate:LIMit:LOWer? {MINimum | MAXimum}

Description

This command sets the lower limit for the present measurement function (used in limit testing).

Parameters

The <value> parameter can take any value between -120% and +120% of the highest (maximum) range for the currently selected function (in the fundamental units for the function). MIN = -120% and MAX = +120%. Default = 0.

For example, if capacitance is the selected measurement, the highest range is 10 mF, and the MAX value is 120% of that: 12 mF.

Remarks

  • You must select the limit math function (CALC:FUNC LIM) and turn on math operations (CALC:STAT ON) before you set a limit value.

  • You can assign a lower limit, an upper limit (see CALCulate:LIMit:UPPer command), or both. The lower limit must always be less than or equal to the upper limit, even if you are using only one of the limits.

  • Limit crossing: If a reading is less than the specified lower limit, bit 11 ("Lower Limit Failed") is set in the Questionable Data Register, which results in an SRQ if enabled. You can use the STATus:QUEStionable[:EVENt]? command to read the event register. See STATus Subsystem Introduction for further information.

  • The instrument clears all the limits after a Factory Reset (*RST command) or when the math function or measurement function is changed.

Return Format

The query command returns the lower limit in the form "-1.00000000E+03".

Examples

The following command sets the lower limit to -0.25.

CALC:LIM:LOW -0.25

The following query returns the lower limit setting.

CALC:LIM:LOW?

Typical Response: -2.50000000E-01

See Also

CALCulate:FUNCtion

CALCulate:LIMit:UPPer

CALCulate:STATe

STATus Subsystem Introduction


CALCulate:LIMit:UPPer

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALCulate:LIMit:UPPer {<value> | MINimum | MAXimum}

CALCulate:LIMit:UPPer? {MINimum | MAXimum}

Description

This command sets the upper limit for the present measurement function (used in limit testing).

Parameters

The <value> parameter can take any value between -120% and +120% of the highest (maximum) range for the currently selected function (in the fundamental units for the function). MIN = -120% and MAX = +120%. Default = 0.

For example, if capacitance is the selected measurement, the highest range is 10 mF, and the MAX value is 120% of that: 12 mF.

Remarks

  • You must select the limit math function (CALC:FUNC LIM) and turn on math operations (CALC:STAT ON) before you set a limit value.

  • You can assign a lower limit (see CALCulate:LIMit:LOWer command), an upper limit, or both. The lower limit must always be less than or equal to the upper limit, even if you are using only one of the limits.

  • Limit crossing: If a reading is greater than the specified upper limit, bit 12 ("Upper Limit Failed") is set in the Questionable Data Register, which results in an SRQ if enabled. You can use the STATus:QUEStionable[:EVENt]? command to read the event register. See STATus Subsystem Introduction for further information.

  • The instrument clears all the limits after a Factory Reset (*RST command) or when the math function or measurement function is changed.

Return Format

The query command returns the upper limit in the form "+1.00000000E+03".

Examples

The following command sets the upper limit to 10.25.

CALC:LIM:UPP 10.25

The following query returns the upper limit setting.

CALC:LIM:UPP?

Typical Response: +1.02500000E+01

See Also

CALCulate:FUNCtion

CALCulate:LIMit:LOWer

CALCulate:STATe

STATus Subsystem Introduction


CALCulate:AVERage:AVERage?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALCulate:AVERage:AVERage?

Description

This command returns the mathematical average of all readings taken since averaging was enabled.

Remarks

  • The instrument clears the stored average data when averaging is enabled, when the CALCulate:FUNCtion command is sent while CALCulate:STATe is ON, when the power has been off, after a Factory Reset (*RST command), or after a function change.

Return Format

The command returns the average of the readings taken, or "0" if no data is available.

Example

The following query returns the average of the readings taken.

CALC:AVER:AVER?

Typical Response: +2.61920000E+01

See Also

CALCulate:AVERage:COUNt?

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:COUNt?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALCulate:AVERage:COUNt?

Description

This command returns the number of readings taken since averaging was enabled.

Remarks

  • The instrument clears the stored average data when averaging is enabled, when the CALCulate:FUNCtion command is sent while CALCulate:STATe is ON, when the power has been off, after a Factory Reset (*RST command), or after a function change.

Return Format

The command returns the count since statistics were enabled. If no data is available , "0" is returned.

Example

The following query returns the number of readings taken since statistics were enabled.

CALC:AVER:COUN?

Typical Response: +20

See Also

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:MAXimum?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALCulate:AVERage:MAXimum?

Description

This command returns the maximum value found since averaging was enabled.

Remarks

  • The instrument clears the stored average data when averaging is enabled, when the CALCulate:FUNCtion command is sent while CALCulate:STATe is ON, when the power has been off, after a Factory Reset (*RST command), or after a function change.

Return Format

The command returns the maximum of the readings taken, or "0" if no data is available.

Example

The following query returns the maximum value found.

CALC:AVER:MAX?

Typical Response: +1.37370000E+03

See Also

CALCulate:AVERage:COUNt?

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:AVERage:MINimum?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALCulate:AVERage:MINimum?

Description

This command returns the minimum value found since averaging was enabled.

Remarks

  • The instrument clears the stored average data when averaging is enabled, when the CALCulate:FUNCtion command is sent while CALCulate:STATe is ON, when the power has been off, after a Factory Reset (*RST command), or after a function change.

Return Format

The command returns the minimum value found, or "0" if no data is available.

Example

The following query returns the minimum value found.

CALC:AVER:MIN?

Typical Response: +4.27150000E-03

See Also

CALCulate:AVERage:COUNt?

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:DB:REFerence

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALCulate:DB:REFerence {<value> | MINimum | MAXimum}

CALCulate:DB:REFerence? {MINimum | MAXimum}

Description

This command stores a reference value in the instrument's dB reference register, which is used for the dB function in the CALCulate:FUNCtion command.

Parameters

The <value> (reference value) parameter can take any value in the range ±120 dBm.
MIN = –120.00 dBm. MAX = +120.00 dBm. The default value is 0 dBm.

Remarks

  • You must select (CALCulate:FUNCtion) and turn on (CALCulate:STATe) math operations before writing to the dB reference Register.

  • The instrument resets the dB reference value to the default after a Factory Reset (*RST command) or when the math function or measurement function is changed.

Return Format

The query command returns the reference value in the form "+1.00000000E+02".

Examples

The following command sets the dB reference value to -10.0 dBm.

CALC:DB:REF -10.0

The following query returns the dB reference value.

CALC:DB:REF?

Typical Response: -1.00000000E+01

See Also

CALCulate:DBM:REFerence

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:DBM:REFerence

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALCulate:DBM:REFerence {<value> | MINimum | MAXimum}

CALCulate:DBM:REFerence? {MINimum | MAXimum}

Description

This command selects the dBm reference resistance. The default is 600 ohms. This reference value affects both the dBm and dB functions in the CALCulate:FUNCtion command.

Parameters

The <value> (dBm reference value) parameter can only take on certain discrete values. Choose from: 2, 4, 8, 16, 50, 75, 93, 110, 124, 125, 135, 150, 250, 300, 500, 600, 800, 900, 1000, 1200, 8000Ω. MIN = 2 ohms. MAX = 8000 ohms. The default value is 600 ohms.

Remarks

  • The dBm reference resistance is not reset when math functions are enabled by the CALCulate:STATe command, nor when a CALCulate:FUNCtion command is sent with CALCulate:STATe set to ON.

  • The dBm reference resistance value is stored in non-volatile memory. It is not affected by a power-on cycle, Factory Reset (*RST command) or function change.

Return Format

The query command returns the dBm reference resistance.

Examples

The following command sets the dBm reference resistance to 300 ohms.

CALC:DBM:REF 300

The following query returns the dBm reference resistance.

CALC:DBM:REF?

Typical Response: +3.00000000E+02

See Also

CALCulate:DB:REFerence

CALCulate:FUNCtion

CALCulate:STATe


CALCulate:NULL:OFFSet

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALCulate:NULL:OFFSet {<value> | MINimum | MAXimum}

CALCulate:NULL:OFFSet? {MINimum | MAXimum}

Description

This command stores a null value in the instrument's Null Register.

Parameters

The <value> parameter can take any value between -120% and +120% of the highest range for the present measurement function. MIN = -120% of the highest range. MAX = +120% of the highest range. The default value is 0.

Remarks

  • You must select (CALCulate:FUNCtion) and turn on (CALCulate:STATe) math operations before you set a null value.

  • The instrument clears the null value after a Factory Reset (*RST command), or when the math function or measurement function is changed.

Return Format

The query command returns the null value in the form "+1.00000000E-02".

Examples

The following command sets the null value to -0.25.

CALC:NULL:OFFS -0.25

The following query returns the null value.

CALC:NULL:OFFS?

Typical Response: -2.50000000E-01

See Also

CALCulate:STATe


CALibration Subsystem Introduction

The CALibration commands are used to calibrate the Keysight 34450A. Please note that the use of these commands requires a detailed knowledge of the appropriate calibration procedures, which are described in the Keysight 34450A Service Guide. Please refer to that guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Command Summary

CALibration[:ALL]?

CALibration:COUNt?

CALibration:SECure:CODE

CALibration:SECure:STATe

CALibration:SECure:STATe?

CALibration:STRing

CALibration:STRing?

CALibration:VALue

CALibration:VALue?

CALibration:STORe

CALibration:FLAT?


CALibration[:ALL]?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALibration[:ALL]?

Description

This command performs a calibration of the multimeter using the specified calibration value (CALibration:VALue command). Before you can calibrate the instrument, you must unsecure it by entering the correct security code.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Remarks

  • If a calibration fails, "+1" is returned and an error is stored in the error queue. For a complete listing of the error messages related to calibration failures, see SCPI Error Messages.

  • This command increments the calibration count on the Keysight 34450A (see CALibration:COUNt? command).

Return Format

The command returns "+0" (calibration passed) or "+1" (calibration failed).

Example

The following command performs a calibration and returns a pass indication.

CAL?

Typical Response: +0

See Also

CALibration:SECure:STATe

CALibration:VALue


CALibration:COUNt?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALibration:COUNt?

Description

This command queries the instrument to determine how many calibrations have been performed. Note that your instrument was calibrated before it left the factory. When you receive your instrument, be sure to read the count to determine the initial values.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Remarks

  • The calibration counts increment up to a maximum of 32767 after which they roll over to "0". Since the value increments by one for each calibration point, a complete calibration may increase the value by many counts.

  • The calibration count is incremented by the CALibration? command. You can read the calibration count whether the instrument is secured or unsecured.

  • The calibration count is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The command returns the calibration count indicating how many calibrations have been performed.

Example

The following command returns the calibration count.

CAL:COUN?

Typical Response: +739

See Also

CALibration?

CALibration:SECure:STATe


CALibration:SECure:CODE

CALibration:FLAT?

Syntax | Description | Remarks | Return Format | Example

Syntax

CALibration:FLAT?

Description

This command performs a calibration on flatness for AC path of the multimeter using the specified calibration value (Calibration:Value command). Set CALibration:VALue 0 to calibrate 1 kHz signal and set CALibration:VALue 1 to calibrate 10 kHz signal. Before you can calibrate the instrument, you must unsecure it by entering the correct security code.

For detailed discussion on the calibration procedures, refer to the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Remarks

If a calibration fails, "+1" is returned and an error is stored in the error queue. For a complete listing of the error messages related to calibration failures, refer to the SCPI Error Messages.

This command increments the calibration count on the Keysight 34450A (see CALibration:COUNt? command).

Return Format

The command returns "+0" (calibration passed) or "+1" (calibration failed).

Example

The following command performs a calibration on 1 kHz signal and returns a pass indication.

CAL:VAL 0
CAL:FLAT?

Typical Response: +0

See Also

CALibration:VALue

CALibration:COUNt?


CALibration:SECure:CODE

Syntax | Description | Parameters | Remarks | Example

Syntax

CALibration:SECure:CODE <new_code>

Description

This command allows you to enter a new security code to prevent accidental or unauthorized calibrations. The specified code is used to unsecure calibration memory. To change the security code, you must first unsecure calibration memory using the old security code, and then enter a new code.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Parameters

Name | Type | Range of Values | Default Value
<new_code> | Unquoted ASCII String | A string of up to 12 characters. You do not have to use all 12 characters but the first character must always be a letter (A-Z). The remaining 11 characters can be letters, numbers (0-9), or the underscore character ("_"). Blank spaces are not allowed. | This is a required parameter

Remarks

  • The security code is set to AT34450 when the instrument is shipped from the factory.

  • If you forget your security code, you can override the security feature. See the Keysight 34450A Service Guide for more information.

The security code is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).

Example

The following command sets a new calibration security code (calibration memory must be unsecured first using the CALibration:SECure:STATe command).

CAL:SEC:CODE T3ST_DUT165

See Also

CALibration:SECure:STATe


CALibration:SECure:STATe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALibration:SECure:STATe {OFF|0|ON|1|RESET}, <code>

CALibration:SECure:STATe?

Description

This command unsecures or secures the instrument for calibration. To unsecure the instrument, you must provide a security code to prevent accidental or unauthorized calibrations of the instrument. Before you can calibrate the instrument, you must unsecure it by entering the correct security code.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1|RESET} | This is a required parameter.
<code> | Unquoted ASCII String | A string of up to 12 characters. You do not have to use all 12 characters but the first character must always be a letter (A-Z). The remaining 11 characters can be letters, numbers (0-9), or the underscore character ("_"). Blank spaces are not allowed. | This parameter is required to disable security, but is optional to enable security (but must be correct if provided).

Remarks

  • When you first receive your instrument, it is secured. The security code is set to AT34450 when the instrument is shipped from the factory.

  • Once you enter a security code, that code must be used for both front-panel and remote-interface calibration. For example, if you secure the instrument from the front panel, you must use that same code to unsecure it from the remote interface.

  • Un-securing the instrument using this command enables the instrument to be calibrated.

  • To calibrate the Keysight 34450A, use the CALibration:VALue and CALibration? commands.

The calibration security setting is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON) indicating the current calibration security setting.

Examples

The following command will unsecure the instrument using the factory default security code.

CAL:SEC:STAT OFF,AT34450

The following query returns the current calibration security setting.

CAL:SEC:STAT?

Typical Response: 0

See Also

CALibration:SECure:CODE


CALibration:STRing

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALibration:STRing "<string>"

CALibration:STRing?

Description

This command allows you to store one message in calibration memory. For example, you can store such information as the date when the last calibration was performed, the date when the next calibration is due, the instrument's serial number, or even the name and phone number of the person to contact for a new calibration.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Parameters

Name | Type | Range of Values | Default Value
<string> | Quoted ASCII String | A string of up to 40 characters enclosed in quotes. You can use letters (A-Z), numbers (0-9), and special characters like "@", "%", "*", etc. | This is a required parameter

Remarks

  • You can record a calibration message only from the remote interface and only when the instrument is unsecured (see CALibration:SECure:STATe OFF command). You can read the message from the remote interface only. You can read the calibration message whether the instrument is secured or unsecured.

  • Storing a calibration message will overwrite any message previously stored in memory.

  • The calibration message is stored in non-volatile calibration memory, and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The query command returns an ASCII string enclosed in double quotes. If no calibration message has been specified, an empty quoted string ("") is returned.

Examples

The following commands store a message in calibration memory.

CAL:STR "CAL: 21 Nov 2005" or CAL:STR 'CAL: 21 Nov 2010'

The following query returns the message currently stored in calibration memory (the quotes are also returned).

CAL:STR?

Typical Response: "CAL: 21 Nov 2010"

See Also

CALibration:SECure:STATe


CALibration:VALue

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

CALibration:VALue <value>

CALibration:VALue?

Description

This command specifies the value of the known calibration signal as outlined in the calibration procedures in the Keysight 34450A Service Guide.

For a more detailed discussion of the calibration procedures, see the Keysight 34450A Service Guide. Please refer to the Keysight 34450A Service Guide before attempting to calibrate the instrument. Improper use of the CALibration commands can adversely affect the accuracy and reliability of the instrument.

Parameters

Name | Type | Range of Values | Default Value
<value> | Numeric | Desired calibration signal in the units specified by the present measurement function. | This is a required parameter

Remarks

  • Refer to the Keysight 34450A Service Guide for detailed procedures, including how to connect a calibration source, recommended equipment, the specified calibration points, and so forth.

Return Format

The query command returns the calibration value in the form "+1.00000000E-01".

Examples

The following command sets calibration value to +10 volts.

CAL:VAL 10

The following query returns the present calibration value.

CAL:VAL?

Typical Response: +1.000000E+01

See Also

CALibration[:ALL]?


CALibration:VALue

CALibration:STORe

Syntax | Description | Remarks | Example

Syntax

CALibration:STORe

Description

This command stores the present function calibration constant in the non-volatile memory.

Remarks

Refer to the Keysight 34450A Service Guide for detailed procedures, which includes how to connect a calibration source, recommended equipment, the specified calibration points, and so forth.

Example

The following command stores calibration results of the current function in the non-volatile memory.

CAL:STOR


CONFigure Subsystem Introduction

The CONFigure command allows you to set the measurement function, range, and resolution without actually making a measurement.

Use the INITiate or READ? command to initiate the measurement.

Command Summary

CONFigure[:PRIMary]?

CONFigure[:PRIMary][:VOLTage]:AC

CONFigure[:PRIMary][:VOLTage][:DC]

CONFigure[:PRIMary]:CURRent:AC

CONFigure[:PRIMary]:CURRent[:DC]

CONFigure[:PRIMary]:DIODe

CONFigure[:PRIMary]:FREQuency

CONFigure[:PRIMary]:RESistance

CONFigure[:PRIMary]:FRESistance

CONFigure[:PRIMary]:TEMPerature

CONFigure[:PRIMary]:CONTinuity

CONFigure[:PRIMary]:CAPacitance

CONFigure:SECondary?

CONFigure:SECondary[:VOLTage]:AC

CONFigure:SECondary[:VOLTage][:DC]

CONFigure:SECondary:CURRent:AC

CONFigure:SECondary:CURRent[:DC]

CONFigure:SECondary:FREQuency

Default Settings for the CONFigure Command

With the CONFigure command, you can select the function, range, and resolution all in one command. All other measurement parameters are set to their default values as shown below.

Measurement Parameter: | CONFigure Setting:
Trigger Source | Immediate
Math Functions | OFF

Using the CONFigure Command

The following program segment shows how to use the CONFigure command with the READ? command to make a measurement. The CONFigure command configures the instrument for DC voltage measurements.

CONF:VOLT:DC
READ?

Typical Response: +4.27150000E-00

50000E-00

The following program segment configures the instrument for 2-wire resistance measurements, triggers the instrument to make one measurement using the INITiate command. The FETC? command retrieves the reading. The 10 kΩ range is selected with resolution set to 3.00E-5.

CONF:RES 10000,3.0
INIT
FETC?

Typical Response: +5.95850000E+03


CONFigure:FREQuency

CONFigure[:PRIMary]?

Syntax | Description | Remarks | Return Format | Example

Syntax

CONFigure[:PRIMary]?

Description

This command returns the present (primary configuration if secondary function is turned on) configuration of the instrument as a quoted string.

Remarks

The *RST command will set all measurement parameters to their factory settings, clear reading memory, and clear all stored statistical data.

Return Format

The command returns a series of comma-separated fields indicating the present function, range, and resolution. The short form of the function name is always returned (e.g., "CURR:AC", "FREQ", etc.).

Example

The following query returns the present configuration of the instrument (the quotes are also returned).

CONF?

Typical Response: "VOLT +1.000000E+01,+3.000000E-05"


CONFigure[:VOLTage]:AC

CONFigure[:PRIMary][:VOLTage]:AC

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary][:VOLTage]:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (primary) AC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC voltage measurements but does not initiate the measurement.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Volts

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 750 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for AC voltage measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

CONF:VOLT:AC
READ?

Typical Response: +1.86850000E+02

The following program segment configures the instrument for AC voltage measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 V range is selected.

CONF:VOLT:AC 1
INIT
FETC?

Typical Response: +4.27150000E-01

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure[:VOLTage][:DC]

CONFigure[:PRIMary][:VOLTage][:DC]

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary][:VOLTage][:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (primary) DC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC voltage measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Volts

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 1000 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for DC voltage measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:VOLT:DC
READ?

Typical Response: +1.86850000E-03

The following program segment configures the instrument for DC voltage measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 V range is selected with a resolution of 3.00E-5.

CONF:VOLT:DC 1,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E-01

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:CAPacitance

CONFigure[:PRIMary]:CAPacitance

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:CAPacitance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all capacitance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for capacitance measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in F (farads):

  • 1 nF (MIN)

  • 10 nF

  • 100 nF

  • 1 µF (DEF)

  • 10 µF

  • 100 µF

  • 1 mF

  • 10 mF (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

Desired resolution in F (farads).

3½ digits

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For fastest measurements, use manual ranging on each measurement (some additional time may be required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for capacitance measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (AUTO) and resolution are used for the measurement.

CONF:CAP
DELAY 0.3 s
READ?

Typical Response: +0.04530000E-06

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:CONTinuity

CONFigure[:PRIMary]:CONTinuity

Syntax | Description | Remarks | Examples

Syntax

CONFigure[:PRIMary]:CONTinuity

Description

First, this command resets all continuity measurement parameters and trigger parameters to their default values. Then, it configures the instrument for continuity measurements but does not initiate a measurement. Continuity is a special type of fixed-range 2-wire resistance measurement.

This command presets the instrument to a fixed range and resolution, and then configures for continuity tests. However, it does not initiate the test.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Remarks

  • The range is fixed at 1 kΩ (a 2-wire resistance measurement) the resolution is fixed at 4½ digits.

  • The meter beeps (even if beep is disabled) for each measurement that is less than or equal to the continuity threshold (≤10 Ω), and the actual resistance reading is displayed on the front panel.

    • From 10 Ω to 1.2 kΩ the meter displays the actual resistance reading with no beep.

    • If the reading exceeds 1.2 kΩ, the meter displays "OPEN" on the front panel (no beep).

  • The FETCh?, READ?, and MEASure[:PRIMary]:CONTinuity? commands return the measured resistance, regardless of its value.

Examples

The following program segment configures the instrument for continuity measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer.

CONF:CONT
READ?

Typical Response: +1.32130000E-02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:CURRent:AC

CONFigure[:PRIMary]:CURRent:AC

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:CURRent:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (primary) AC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC current measurements but does not initiate a measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Amps

  • 10 mA (MIN)

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for AC current measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

CONF:CURR:AC
READ?

Typical Response: +8.54530000E-02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:CURRent[:DC]

CONFigure[:PRIMary]:CURRent[:DC]

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:CURRent[:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (primary) DC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC current measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Amps

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately determine the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for DC current measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:CURR:DC
READ?

Typical Response: +8.54530000E-03

The following program segment configures the instrument for DC current measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 A range is selected with a resolution of 3.00E-5.

CONF:CURR:DC 1A,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E-02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:DIODe

CONFigure[:PRIMary]:DIODe

Syntax | Description | Remarks | Examples

Syntax

CONFigure[:PRIMary]:DIODe

Description

First, this command resets all diode test parameters and trigger parameters to their default values. Then it configures the instrument for diode tests, but does not initiate the test.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Remarks

  • The range and resolution are fixed for diode tests: The range is 1 Vdc (with a 1 mA current source output) the resolution is fixed at 4½ digits.

  • The voltage is returned if it is in the 0 to 1.2 volt range. The instrument beeps when the signal transitions to the 0.3 to 0.8 volt threshold (unless beep is disabled). If the signal is greater than 1.2 volts, OPEn is displayed on the front panel and "+9.9E+37" is returned from the remote interface.

  • The FETCh?, READ?, and MEASure:DIODe? commands return the measured voltage, regardless of its value.

Examples

The following program segment configures the instrument for diode tests. The READ? command places the instrument in the "wait-for-trigger" state, triggers a test, and then sends the reading to memory and the instrument output buffer.

CONF:DIOD
READ?

Typical Response: +1.32130000E-01

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:FREQuency

CONFigure[:PRIMary]:FREQuency

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:FREQuency [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all frequency measurement parameters and trigger parameters to their default values. Then, it configures the instrument for frequency measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name | Type | Range of Values | Default Value
<range> | Numeric | Approximate frequency of the input signal in hertz, between 1 Hz and 1 MHz. MIN = 1 Hz DEF = 1 Hz MAX = 1 MHz | 1 Hz
<resolution> | Numeric | Desired resolution in hertz | 5½ digits

Remarks

  • Frequency is measured on AC voltage signals if previous function selected is not CURR:AC. Thus, the proper AC voltage range should be set first using the [SENSe:][PRIMary:]FREQuency:VOLTage:RANGe command. The voltage range should be 0.1 volts or greater for more accurate frequency measurements.

  • The <range> parameter is required only to specify the measurement resolution parameter. Therefore, it is not necessary to send a new command for each new frequency to be measured.

  • To measure frequency on AC current signal, configure the instrument to AC current (CONF:CURR:AC); followed by frequency (CONF:FREQ)

  • With no signal applied, "0" is returned.

Examples

The following program segment configures the instrument for frequency measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer.

CONF:FREQ
READ?

Typical Response: +1.32130000E+03

The following program segment configures the instrument for frequency measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument's output buffer.

CONF:FREQ 1
INIT
FETC?

Typical Response: +1.01230000E+02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe


CONFigure:RESistance

CONFigure[:PRIMary]:FRESistance

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:FRESistance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all 4-wire resistance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for 4-wire resistance measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Ohms (Ω)

  • 100 Ω (MIN)

  • 1 kΩ (DEF)

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for 4-wire resistance measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:FRES
READ?

Typical Response: +1.32130000E+04

The following program segment configures the instrument for 4-wire resistance measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 kΩ range is selected with resolution set to 3.00E-5.

CONF:FRES 1000,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E+02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:RESistance

CONFigure[:PRIMary]:RESistance

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[:PRIMary]:RESistance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all 2-wire resistance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for 2-wire resistance measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Ohms (Ω)

  • 100 Ω (MIN)

  • 1 kΩ (DEF)

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Examples

The following program segment configures the instrument for 2-wire resistance measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:RES
READ?

Typical Response: +1.32130000E+04

The following program segment configures the instrument for 2-wire resistance measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 kΩ range is selected with resolution set to 3.00E-5.

CONF:RES 1000,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E+02

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:TEMPerature

CONFigure[:PRIMary]:TEMPerature

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure[PRIMary]:TEMPerature [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]

Description

First, this command resets all temperature measurement parameters and trigger parameters to their default values. Then, it configures the instrument for temperature measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name | Type | Range of Values | Default Value
<probe_type> | Discrete | {THERmistor} | Required parameter: DEF sets THER
<type> | Discrete | {5000} | Required parameter: DEF sets 5000
<resolution> | Numeric | Desired resolution in the currently selected units (°C or °F) | 3½ digits

Remarks

  • For temperature measurements, the instrument internally selects the range−you cannot select the range to be used.

  • For temperature measurements, the resolution is fixed at 3½ digits.

  • To change temperature units, use the UNIT:TEMPerature command.

  • For thermistor measurements, the instrument auto ranges to the correct range for the transducer resistance measurement.

Examples

The following program segment configures the instrument for 5 kΩ, 2-wire thermistor measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer.

CONF:TEMP THER,5000
INIT
FETC?

Typical Response: +7.78000000E+01

See Also

CONFigure[:PRIMary]?

FETCh?

INITiate[:IMMediate]

READ?

UNIT:TEMPerature


CONFigure:FREQuency

CONFigure:SECondary?

Syntax | Description | Remarks | Return Format | Example

Syntax

CONFigure:SECondary?

Description

This command returns the secondary function configuration of the instrument as a quoted string.

Remarks

The *RST command will set all measurement parameters to their factory settings, clear reading memory, and clear all stored statistical data.

Return Format

The command returns a series of comma-separated fields indicating the present function, range, and resolution. The short form of the function name is always returned (e.g., "CURR:AC", "FREQ", etc.).

Example

The following query returns the secondary configuration of the instrument (the quotes are also returned).

CONF:SEC?

Typical Response: "VOLT +1.000000E+01,+3.000000E-05"


CONFigure:SECondary[:VOLTage]:AC

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure:SECondary[:VOLTage]:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (secondary) AC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC voltage measurements but does not initiate the measurement.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Volts

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 750 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Examples

The following program segment configures the instrument for AC voltage measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

CONF:SEC:VOLT:AC
READ?

Typical Response: +1.86850000E+02

The following program segment configures the instrument for AC voltage measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 V range is selected.

CONF:SEC:VOLT:AC 1
INIT
FETC?

Typical Response: +4.27150000E-01

See Also

CONFigure:SECondary?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:SECondary[:VOLTage][:DC]

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure:SECondary[:VOLTage][:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (secondary) DC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC voltage measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Volts

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 1000 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Examples

The following program segment configures the instrument for DC voltage measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:SEC:VOLT:DC
READ?

Typical Response: +1.86850000E-03

The following program segment configures the instrument for DC voltage measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 V range is selected with resolution set to 3.00E-5.

CONF:SEC:VOLT:DC 1,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E-01

See Also

CONFigure:SECondary?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:SECondary:CURRent:AC

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure:SECondary:CURRent:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (secondary) AC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC current measurements but does not initiate a measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Amps

  • 10 mA (MIN)

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "9.9E+37" from the remote interface.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Examples

The following program segment configures the instrument for AC current measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

CONF:SEC:CURR:AC
READ?

Typical Response: +8.54530000E-02

See Also

CONFigure:SECondary?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:SECondary:CURRent[:DC]

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure:SECondary:CURRent[:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (secondary) DC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC current measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in Amps

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately determine the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Examples

The following program segment configures the instrument for DC current measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

CONF:SEC:CURR:DC
READ?

Typical Response: +8.54530000E-03

The following program segment configures the instrument for DC current measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument output buffer. The 1 A range is selected with a resolution of 3.00E-5.

CONF:SEC:CURR:DC 1A,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E-02

See Also

CONFigure:SECondary?

FETCh?

INITiate[:IMMediate]

READ?


CONFigure:SECondary::FREQuency

Syntax | Description | Parameters | Remarks | Examples

Syntax

CONFigure:SECondary:FREQuency [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all (secondary) frequency measurement parameters and trigger parameters to their default values. Then, it configures the instrument for frequency measurements but does not initiate the measurement.

The CONFigure command does not place the instrument in the "wait-for-trigger" state. Use the INITiate or READ? command in conjunction with CONFigure to place the instrument in the "wait-for-trigger" state.

Parameters

Name | Type | Range of Values | Default Value
<range> | Numeric | Approximate frequency of the input signal in hertz, between 1 Hz and 1 MHz. MIN = 1 Hz DEF = 1 Hz MAX = 1 MHz | 1 Hz
<resolution> | Numeric | Desired resolution in hertz. | 5½ digits

Remarks

  • Frequency is measured on AC voltage signals if primary function is VOLT:AC. Thus, the proper AC voltage range should be set first using the [SENSe:][PRIMary:]FREQuency:VOLTage:RANGe command. The voltage range should be 0.1 volts or greater for more accurate frequency measurements

  • Frequency is measured on AC current signals if primary function is CURR:AC. Thus, the proper AC current range should be set first using the [SENSe:][PRIMary:]FREQuency:CURRent:RANGe command. The current range should be 0.01 amps or greater for more accurate frequency measurements

  • The <range> parameter is required only to specify the measurement resolution parameter. Therefore, it is not necessary to send a new command for each new frequency to be measured.

  • With no signal applied "0" is returned.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Examples

The following program segment configures the instrument for frequency measurements. The READ? command places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer.

CONF:SEC:FREQ
READ?

Typical Response: +1.32130000E+03

The following program segment configures the instrument for frequency measurements. The INITiate command places the instrument in the "wait-for-trigger" state, triggers a measurement, and stores the reading in memory. The FETCh? command transfers the reading from reading memory to the instrument's output buffer.

CONF:SEC:FREQ 1
INIT
FETC?

Typical Response: +1.01230000E+02

See Also

CONFigure:SECondary?

FETCh?

INITiate[:IMMediate]

READ?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe


DATA Subsystem Introduction

Command Summary

DATA:DATA? NVMEM

DATA:DELete NVMEM

DATA:LAST?

DATA:POINts? NVMEM


DATA:DATA? NVMEM

Syntax | Description | Remarks | Examples

Syntax

DATA:DATA? NVMEM

Description

This command returns all reading stored in non-volatile memory (Data Log Function)

Remarks

  • The internal non-volatile memory can store up to 5,000 readings (by default)

  • The internal non-volatile memory can store up to 50,000 readings (with license option 3445MEMU installed)

Example

The following command returns all readings from non-volatile memory (NVMEM).

DATA:DATA? NVMEM

See Also

DATA:DELete


DATA:DELete NVMEM

Syntax | Description | Remarks | Examples

Syntax

DATA:DELete NVMEM

Description

Deletes all readings from non-volatile memory (NVMEM).

Remarks

  • The internal non-volatile memory is not erased by a power-down cycle. If data has been copied into non-volatile memory (using the DATA:COPY command), use DATA:DELete to erase the readings

Examples

The following command deletes all readings from non-volatile memory

DATA:DELete NVMEM

See Also

DATA:DATA?


DATA:LAST?

Syntax | Description | Remarks | R eturn Format |Examples

Syntax

DATA:LAST?

Description

This command returns the last measurement log in data logging.

Remarks

  • User can execute this command at any time, even during a series of measurements.

  • The instrument will not clears log readings from non-volatile memory after a Factory Reset (*RST command), after an Instrument Preset (SYSTem:PRESet command), or when mainframe power is cycled.

Return Format

This command returns one reading with units. If no data is available, "9.91000000E+37" is returned.

Examples

The following query returns the last reading log by the meter.

DATA:LAST?

Typical Response: +1.73730000E-03 VDC


DATA:POINts? NVMEM

Syntax | Description | Remarks | Examples

Syntax

DATA:POINts? NVMEM

Description

Returns the total number of readings currently stored in non-volatile memory (NVMEM).

Remarks

  • The command returns between 0 and 50,000 readings.

  • You are able to read the count at any time, even during a series of measurements.

  • Non-volatile memory (NVMEM) can store up to 50,000 readings:

    • 1 to 5,000 reading (by default)

    • 1 to 50,000 readings (with license option 3445MEMU installed)

  • The instrument will not clears log readings from memory after a Factory Reset (*RST command), after an Instrument Preset (SYSTem:PRESet command), or when mainframe power is cycled.

Return Format

The query returns a value between 0 and 50,000 readings.

Examples

The following query returns the number of readings in reading memory.

DATA:POIN? NVMEM

Typical Response: +215


DISPlay Subsystem Introduction

Command Summary

DISPlay[:WINDow1][:STATe]

DISPlay[:WINDow1][:STATe]?

DISPlay:WINDow2[:STATe]

DISPlay:WINDow2[:STATe]?


DISPlay[:STATe]

DISPlay[:WINDow1][:STATe]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

DISPlay[:WINDow1][:STATe] <mode>

DISPlay[:WINDow1][:STATe]?

Description

This command enables or disables the entire front panel display. For security reasons or for a slight increase in the measurement rates, you may want to turn off the front-panel display. When the display is disabled, the front-panel display goes blank with all the display annunciators disabled except for Remote and ERROR annunciator.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • The front-panel display can only be disabled from the remote interface only.

  • A return to local mode will enabled the display.

  • The display setting is not stored as part of the instrument state by the *SAV command.

  • The front-panel display is automatically enabled during power-cycle, after a Factory Reset (*RST command), or after an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables the front-panel display.

DISP OFF

The following query returns the front-panel display setting.

DISP?

Typical Response: 0


DISPlay:WINDow2[:STATe]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

DISPlay:WINDow2[:STATe] <mode>

DISPlay:WINDow2[:STATe]?

Description

This command controls the instrument's secondary front-panel display.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • OFF will also turn off the secondary measurement function.
  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables the front-panel secondary display.

DISP:WIND2 OFF

The following query returns the front-panel display setting.

DISP:WIND2?

Typical Response: 0


FETCh Subsystem Introduction

Command Summary

FETCh?


FETCh?

Syntax | Description | Remarks | Return Format | Example

Syntax

FETCh?

Description

This command transfers the reading to the instrument's output buffer where you can read it into your computer. The reading is not erased when read. You can send the command multiple times to retrieve the same reading from memory.

Remarks

  • The FETCh? command will wait until the measurement is complete to terminate.

  • The instrument clears any reading from volatile memory after a Factory Reset (*RST command) when mainframe power is cycled, when the configuration is changed (see CONFigure), or on an INITiate command.

Return Format

The command returns a single reading. If secondary function is set to ON, FETCh? will return readings for both primary and secondary function.

Example

The following program segment shows how to use the FETCh? command with the CONFigure and INITiate commands. The INITiate command places the instrument in the "wait-for-trigger" state. The FETCh? command retrieves the reading from the instrument's output buffer.

CONF:VOLT:DC 10,3.0e-5
INIT
FETC?

Typical Response: +4.27150000E-03

See Also

INITiate[:IMMediate]


FETCh Subsystem Introduction

FORMat Subsystem Introduction

Command Summary

FORMat:OUTPut


FETCh?

FORMat:OUTPut

Syntax | Description | Remarks | Return Format

Syntax

FORMat:OUTPut [{1|2}]

FORMat:OUTPut?

Description

  • 1 = Displays measurement values without measurement unit.

  • 2 = Displays measurement values with measurement unit.

Remarks

  • The query returns whether the measurement unit is included or vice-versa.

  • Refer to table below for output unit for each of the measurement function.

Measurement Function | Unit
DC Voltage | VDC
AC Voltage | VAC
DC Current | ADC
AC Current | AAC
Resistance | OHMS
Frequency | HZ
Diode | VDC
Continuity test | OHMS
Capacitance | F
Temperature | CEL or FAH

Return Format

The command returns either "1" or "2" .

Examples

The following command set the output display format to display measurement values with measurement unit.

FORM:OUTP 2

The following query returns the format output setting.

FORM:OUTP?

Typical Response: +2


IEEE-488 Common Commands Introduction

Command Summary

*CLS

*ESE

*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*PCS

*PCS?

*RST

*SRE

*SRE?

*STB?

*TRG

*TST?

*WAI

*RCL

*SAV


*CLS

Syntax | Description | Example

Syntax

*CLS

Description

This command clears the event registers in all register groups. This command also clears the Error queue.

Example

The following command clears the event register bits.

*CLS

See Also

*ESR?


*ESE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

*ESE <enable_value>

*ESE?

Description

This command enables bits in the enable register for the Standard Event Register group. The selected bits are then reported to bit 5 of the Status Byte Register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below) | This is a required parameter

Remarks

  • The following table lists the bit definitions for the Standard Event Register.

Bit Number | Decimal Value | Definition
0 Operation Complete | 1 | All commands prior to and including *OPC have been executed.
1 Not Used | Not Used | "0" is returned.
2 Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query has been read. Or, both the input and output buffers are full.
3 Device-Specific Error | 8 | A device-specific error, including a self-test error or calibration error, occurred (an error in the -300 range or any positive error has been generated). For a complete listing of the error messages, see SCPI Error Messages.
4 Execution Error | 16 | An execution error occurred (an error in the -200 range has been generated).
5 Command Error | 32 | A command syntax error occurred (an error in the -100 range has been generated).
6 Not Used | Not Used | "0" is returned.
7 Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.

  • Use the <enable_value> parameter to specify which bits will be enabled. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 2 (decimal value = 4), bit 3 (decimal value = 8), and bit 7 (decimal value = 128), the corresponding decimal value would be 140 (4 + 8 + 128).

  • You can use the *PSC command to control whether the Standard Event enable register is cleared at power on.

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

Return Format

  • The query command returns a value from 0 to 65,535.

  • The query command reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 7 (decimal value = 128) are enabled, the query command will return "+136".

Examples

The following command enables bit 4 (decimal value = 16) in the enable register. If an Execution Error occurs, this condition will be reported to the Status Byte Register (bit 5 will be set high).

*ESE 16

The following query returns which bits are enabled in the register.

*ESE?

Typical Response: +16

See Also

*ESR?

*PSC


*ESR?

Syntax | Descri ption | Remarks | Return Format | Example

Syntax

*ESR?

Description

This command queries the event register for the Standard Event Register group. This is a read-only register and the bits are not cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Remarks

  • The following table lists the bit definitions for the Standard Event Register.

Bit Number | Decimal Value | Definition
0 Operation Complete | 1 | All commands prior to and including *OPC have been executed.
1 Not Used | Not Used | "0" is returned.
2 Query Error | 4 | The instrument received a query and tried to read the output buffer but it was empty. Or, a query with bad syntax was received. Or, a new command line was received before a previous query has been read. Or, both the input and output buffers are full.
3 Device-Specific Error | 8 | A device-specific error, including a self-test error or calibration error, occurred (an error in the -300 range or any positive error has been generated). For a complete listing of the error messages, see SCPI Error Messages.
4 Execution Error | 16 | An execution error occurred (an error in the -200 range has been generated).
5 Command Error | 32 | A command syntax error occurred (an error in the -100 range has been generated).
6 Not Used | Not Used | "0" is returned.
7 Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.

  • In order to be reported to the Standard Event Register, the corresponding bits in the event register must be enabled using the *ESE command.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

Return Format

  • This query command returns a value from 0 to 65,535.

  • The command reads the event register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 2 (decimal value = 4) and bit 4 (decimal value = 16) are set (and the corresponding bits are enabled), this command will return "+20".

Example

The following command reads the event register (bits 3 and 4 are set).

*ESR?

Typical Response: +24

See Also

*ESE

*CLS


*IDN?

Syntax | Description | Return Format | Example

Syntax

*IDN?

Description

This command reads the instrument's (mainframe) identification string which contains four comma-separated fields. The first field is the manufacturer's name, the second field is the instrument model number, the third field is the serial number, and the fourth field is a I/O board firmware revision code, and the fifth field shows the measurement board firmware version.

Return Format

The command returns a string with the following format:

Keysight Technologies,34450A,<Serial Number>,II.II-MM.MM

II.II | = I/O board firmware version
MM.MM | = Measurement board firmware version

Example

The following query returns the instrument's identification string.

*IDN?

Typical Response: Keysight Technologies,34450A,MY12345678,01.00-01.00

See Also

*TST?


*OPC

Syntax | Description | Remarks | Example

Syntax

*OPC

Description

This command sets the "Operation Complete" bit (bit 0) in the Standard Event register at the completion of the current operation.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Remarks

  • The purpose of this command is to synchronize your application with the instrument.

  • Note the difference between the *OPC command and the *OPC? query command. The latter returns "1" to the output buffer at the completion of the current operation.

Example

The following command sets the "Operation Complete" bit.

*OPC

See Also

*OPC?


*OPC?

Syntax | Description | Remarks | Return Format | Example

Syntax

*OPC?

Description

This command returns "1" to the output buffer at the completion of the current operation.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Remarks

  • The purpose of this command is to synchronize your application with the instrument.

  • Note the difference between the *OPC? command and the *OPC command. The latter sets the "Operation Complete" bit (bit 0) in the Standard Event register at the completion of the current operation.

Return Format

The command returns "1" to the output buffer.

Example

The following command sends "1" to the output buffer.

*OPC?

See Also

*OPC


*PSC

Syntax | Description | Return Format | Examples

Syntax

*PSC {0|1}

*PSC?

Description

Power-On Status Clear. This command enables or disables the clearing of certain enable registers at power on. With *PSC 0 specified, these registers are not cleared at power on. With *PSC 1 specified, these registers are cleared at power on. The following registers are affected:

  • Questionable Data Register:

STATus:QUEStionable:ENABle

  • Standard Operation Register:

STATus:OPERation:ENABle

  • Status Byte Register:

*SRE (Service Request Enable)

  • Standard Event Register:

*ESE (Event Status Enable)

The *PSC command does not affect the clearing of the condition or event registers, just the enable registers. For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Return Format

The query command returns "0" (do not clear at power on) or "1" (clear at power on).

Examples

The following command disables the power-on clearing of the affected registers.

*PSC 0

The following query returns the power-on status clear setting.

*PSC?

Typical Response: 0

See Also

*SRE

*STB?


*RCL

Syntax | Description | Remarks | Example

Syntax

*RCL {0|1|2|3|4|5}

Description

This command recalls the instrument state stored in the specified storage location. If you recall the instrument state from an empty storage location, it will automatically reset the instrument to factory default setting. When shipped from the factory, storage locations 1 through 5 are empty (location 0 has the power-down state).

Use the *SAV command to store the current instrument state.

Remarks

  • The instrument has five storage locations in non-volatile memory to store instrument states. The instrument uses location 0 to automatically hold the state of the instrument at power down.

  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten.

Example

The following command recalls the instrument state previously stored in location 1.

*RCL 1

See Also

*SAV


*RST

Syntax | Description | Remarks | Example

Syntax

*RST

Description

This command resets the multimeter to the Factory configuration. See Factory Reset State for a complete listing of the instrument's Factory configuration.

Remarks

  • This command does not affect any previously-stored instrument states (see *SAV command).

Example

The following command resets the instrument.

*RST


*SAV

Syntax | Description | Remarks | Example

Syntax

*SAV {0|1|2|3|4|5}

Description

This command stores (saves) the current instrument state in the specified storage location. Any state previously stored in the same location is overwritten (no error is generated).

Use the *RCL command to recall a stored instrument state.

Remarks

  • The instrument has five storage locations in non-volatile memory to store instrument states. The instrument uses location 0 to automatically hold the state of the instrument at power down. You can store the instrument state in location 1, 2, 3, 4, or 5. You can use location 0 to store a fifth instrument state, but keep in mind that location 0 is automatically overwritten when power is cycled.

  • When shipped from the factory, storage locations 1 through 5 are empty and the instrument is configured to issue a factory reset (*RST command) when power is restored. You can change the factory configuration such that the power-down state (location 0) is automatically recalled when power is restored.

  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten.

Example

The following command stores the current instrument state in location 1.

*SAV 1

See Also

*RCL


*SRE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

*SRE <enable_value>

*SRE?

Description

This command enables bits in the enable register for the Status Byte Register group. Once enabled, the corresponding bits may generate a Request for Service (RQS) in the Status Byte. This RQS event may generate a "call back" to your application as a type of asynchronous interrupt.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | This is a required parameter

Remarks

  • The following table lists the bit definitions for the Status Byte Register.

Bit Number | Decimal Value | Definition
0 Not Used | 1 | Always zero.
1 Not Used | 2 | Always zero.
2 Error Queue | 4 | One or more errors have been stored in the Error Queue. Use the SYSTem:ERRor? command to read and delete errors.
3 Questionable Data Summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 Message Available | 16 | Data is available in the instrument's output buffer.
5 Standard Event Summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 Master Summary | 64 | One or more bits are set in the Status Byte Register and may generate a Request for Service (RQS). Bits must be enabled using the *SRE command.
7 Standard Operation Summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).

  • Use the <enable_value> parameter to specify which bits will be enabled. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 3 (decimal value = 8) and bit 5 (decimal value = 32), the corresponding decimal value would be 40 (8 + 32).

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

  • The *PSC (power-on status clear) command determines whether or not the Status Byte enable register is cleared at power on, or not cleared.

  • A *CLS, or *RST command does not clear the bits in the Status Byte enable register.

Return Format

The query command reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 5 (decimal value = 32) are enabled, the query command will return "+40".

Examples

The following command enables bit 4 (decimal value = 16) in the enable register.

*SRE 16

The following query returns which bits are enabled in the register.

*SRE?

Typical Response: +16

See Also

*STB?


*STB?

Syntax | Description | Remarks | Return Format | Example

Syntax

*STB?

Description

This command queries the condition register for the Status Byte Register group. This command is similar to a Serial Poll but it is processed like any other instrument command. This is a read-only register and the bits are not cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Introduction section.

Remarks

  • The following table lists the bit definitions for the Status Byte Register.

Bit Number | Decimal Value | Definition
0 Not used | 1 | Always zero.
1 Not Used | 2 | Always zero.
2 Error Queue | 4 | One or more errors have been stored in the Error Queue. Use the SYSTem:ERRor? command to read and delete errors.
3 Questionable Data Summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 Message Available | 16 | Data is available in the instrument's output buffer.
5 Standard Event Summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 Master Summary | 64 | One or more bits are set in the Status Byte Register and may generate a Request for Service (RQS). Bits must be enabled using the *SRE command.
7 Standard Operation Summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).

  • This command returns the same results as a Serial Poll but the "Master Summary" bit (bit 6) is not cleared if a Serial Poll has occurred.

  • A Factory Reset (*RST command) or power-on cycle will clear all bits in the condition register.

Return Format

The command reads the condition register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 3 (decimal value = 8 and bit 5 (decimal value = 32) are set (and the corresponding bits are enabled), this command will return "+40".

Example

The following command reads the condition register (bits 3 and 5 are set).

*STB?

Typical Response: +40

See Also

*PSC

*SRE


*TRG

Syntax | Description | Remarks | Example

Syntax

*TRG

Description

This command is used in conjunction with the TRIGger:SOURce command to trigger the instrument from the remote interface.

Remarks

  • Use the TRIGger:SOURce command to select the BUS (software) trigger source.

  • After setting the trigger source, you must place the multimeter in the "wait-for-trigger" state using the INITiate command. The *TRG command will not be accepted unless the multimeter is in the "wait-for-trigger" state.

Example

The following command triggers the instrument.

TRIG:SOUR BUS
INIT
*TRG

See Also

TRIGger:SOURce


*TST?

Syntax | Description | Remarks | Return Format | Example

Syntax

*TST?

Description

This command performs a complete self-test of the instrument and returns a pass/fail indication. The self-test runs a series of tests and will take a few seconds to complete. If all tests pass, you can have a high confidence that the instrument is operational.

Remarks

  • If one or more tests fail, "+1" is returned and an error is stored in the error queue. For a complete listing of the error messages related to self-test failures, see SCPI Error Messages.

  • If one or more tests fail, see the Keysight 34450A Service Guide for instructions on obtaining service.

  • Following the *TST? command, the instrument issues a Factory Reset (*RST command).

Return Format

The command returns "+0" (all tests passed) or "+1" (one or more tests failed).

Example

The following command performs a self-test and returns a pass/fail indication.

*TST?

Typical Response: +0

See Also

*IDN?


*WAI

Syntax | Description | Remarks | Example

Syntax

*WAI

Description

This command configures the instrument's output buffer to wait for all pending operations to complete before executing any additional commands over the interface.

Remarks

Function and range changes are considered pending operations. Therefore, *WAI will cause these changes to occur and complete.

Example

The following command waits until all pending operations complete.

*WAI

See Also

*OPC


MEASure Subsystem Introduction

The MEASure? command provides the easiest way to program the instrument for measurements. When you execute this command, the instrument immediately performs the measurement (see Triggering the Multimeter for details). The reading is sent directly to the instrument's output buffer. For voltage, current, and frequency measurements you can use the SECondary command to send measurement readings to the secondary display.

Command Summary

MEASure[:PRIMary]:CURRent:AC?

MEASure[:PRIMary]:CURRent[:DC]?

MEASure[:PRIMary]:DIODe?

MEASure[:PRIMary]:FREQuency?

MEASure[:PRIMary]:RESistance?

MEASure[:PRIMary]:FRESistance?

MEASure[:PRIMary]:TEMPerature?

MEASure[:PRIMary][:VOLTage]:AC?

MEASure[:PRIMary][:VOLTage][:DC]?

MEASure[:PRIMary]:CAPacitance?

MEASure:SECondary:CURRent:AC?

MEASure:SECondary:CURRent[:DC]?

MEASure:SECondary:FREQuency?

MEASure:SECondary[:VOLTage][:DC]?

MEASure:SECondary[:VOLTage]:AC?

Default Settings for the MEASure? Command

With the MEASure? command, you can select the function, range, and resolution all in one command. All other measurement parameters are set to their default values as shown below.

Measurement Parameter: | CONFigure Setting:
Trigger Source | Immediate
Math Functions | OFF

Using the MEASure? Command

The following command shows how to use the MEASure? command to make a measurement. This example configures the instrument for DC voltage measurements, internally triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (autorange) and resolution (1 ;) are used for the measurement.

MEAS:VOLT:DC?

Typical Response: +4.23450000E-03

The following command configures the instrument for 2-wire resistance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 kΩ range is selected with resolution set to 3.00E-5.

MEAS:RES? 1000,3.0e-5

Typical Response: +3.27150000E+02


MEASure[:VOLTage]:AC?

MEASure[:PRIMary][:VOLTage]:AC?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary][:VOLTage]:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all primary AC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC voltage measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 750 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for AC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

MEAS:VOLT:AC?

Typical Response: +1.86850000E-03

The following command configures the instrument for AC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 V range is selected.

MEAS:VOLT:AC? 1

Typical Response: +4.27150000E-03

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure[:VOLTage][:DC]?

MEASure[:PRIMary][:VOLTage][:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary][:VOLTage][:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all primary DC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC voltage measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 1000 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for DC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

MEAS:VOLT:DC?

Typical Response: +1.86850000E-03

The following command configures the instrument for DC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 V range is selected with resolution set to 3.00E-5.

MEAS:VOLT:DC? 1,3.0e-5

Typical Response: +4.27150000E-03

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:CAPacitance?

MEASure[:PRIMary]:CAPacitance?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:CAPacitance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all capacitance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for capacitance measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in F (farads):

  • 1 nF (MIN)

  • 10 nF

  • 100 nF

  • 1 µF (DEF)

  • 10 µF

  • 100 µF

  • 1mF

  • 10mF (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

Desired resolution in F (farads).

3½ digits

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input. For fastest measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • Auto range thresholds:

Down range at: | <10% of range
Up range at: | >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for capacitance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (AUTO) and resolution (4½ digits) are used for the measurement.

MEAS:CAP?

Typical Response: +0.04530000E-06

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:CONTinuity?

MEASure[:PRIMary]:CONTinuity?

Syntax | Description | Remarks | Examples

Syntax

MEASure[:PRIMary]:CONTinuity?

Description

First, this command resets all continuity measurement parameters and trigger parameters to their default values. Then it configures the instrument for continuity tests, and immediately triggers the test. Continuity is a special type of fixed-range 2-wire resistance measurement. The reading is sent directly to the instrument output buffer.

Remarks

  • The range is fixed at 1 kΩ (a 2-wire resistance measurement) the resolution is fixed at 4½ digits.

  • The meter beeps (even if beep is disabled) for each measurement that is less than or equal to the continuity threshold (≤10 Ω), and the actual resistance reading is displayed on the front panel.

    • From 10 Ω to 1.2 kΩ the meter displays the actual resistance reading with no beep.

    • If the reading exceeds 1.2 kΩ, the meter displays "OPEN" on the front panel (no beep).

  • The MEASure:[PRIMary:]CONTinuity? command returns the measured resistance, regardless of its value.

  • Either the *RST command will set all measurement parameters to their factory settings, clear reading memory, and clear all stored statistical data.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

    • Return Format

    The command returns a single reading.

    Examples

    The following command configures the instrument for continuity measurements, places the instrument in the "wait-for-trigger" state, triggers a measurement, and then sends the reading to memory and the instrument output buffer.

    MEAS:CONT?

    Typical Response: +1.32130000E-02

    See Also

    CONFigure[:PRIMary]?

    FETCh?

    READ?


MEASure:CURRent:AC?

MEASure[:PRIMary]:CURRent:AC?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:CURRent:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all primary AC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC current measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in amps:

  • 10 mA (MIN)

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For fastest measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for AC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution are used for the measurement.

MEAS:CURR:AC?

Typical Response: +8.54530000E-02

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:CURRent[:DC]?

MEASure[:PRIMary]:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:CURRent[:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all primary DC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC current measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in amps:

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for DC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

MEAS:CURR:DC?

Typical Response: +8.54530000E-03

The following command configures the instrument for DC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 A range is selected with resolution set to 3.00E-5.

MEAS:CURR:DC? 1,3.0e-5

Typical Response: +4.27150000E-02

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:DIODe?

MEASure[:PRIMary]:DIODe?

Syntax | Description | Remarks | Examples

Syntax

MEASure[:PRIMary]:DIODe?

Description

First, this command resets all diode test parameters and trigger parameters to their default values. Then it configures the instrument for diode tests, and immediately triggers the test. The reading is sent directly to the instrument output buffer.

Remarks

  • The range is fixed at 1 Vdc (with a 1 mA current source output) and the resolution is fixed at 4½ digits.

  • The voltage is returned if it is in the 0 to 1.2 volt range. The instrument beeps when the signal transitions to the 0.3 to 0.8 volt threshold (unless beep is disabled). If the signal is greater than 1.2 volts, OPEn is displayed on the front panel and "+9.9E+37" is returned from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for diode tests, places the instrument in the "wait-for-trigger" state, triggers a test, and then sends the reading to memory and the instrument output buffer.

MEAS:DIOD?

Typical Response: +0.65120000E-00

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:FREQuency?

MEASure[:PRIMary]:FREQuency?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:FREQuency? [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all primary frequency measurement parameters and trigger parameters to their default values. Then, it configures the instrument for frequency measurements and immediately triggers a measurement. The results are sent directly to the instrument output buffer.

Parameters

Name | Type | Range of Values | Default Value
<range> | Numeric | Approximate frequency of the input signal in hertz, between 1 Hz and 1 MHz. MIN = 1 Hz DEF = 1 Hz MAX = 1 MHz | 1 Hz
<resolution> | Numeric | Desired resolution in hertz. | 5½ digits

Remarks

  • Frequency is measured on AC voltage signals. Thus, the proper AC voltage range should be set first using the [SENSe:][PRIMary:]FREQuency:VOLTage:RANGe command. The voltage range should be 0.1 volts or greater for more accurate frequency measurements.

  • The <range> parameter is required only to specify the measurement resolution parameter. Therefore, it is not necessary to send a new command for each new frequency to be measured.

  • With no signal applied "0" is returned.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for frequency measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer.

MEAS:FREQ?

Typical Response: +1.32130000E+03

See Also

CONFigure[:PRIMary]?

FETCh?

READ?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe


MEASure:RESistance?

MEASure[:PRIMary]:FRESistance?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:FRESistance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all resistance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for 4-wire resistance measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in ohms:

  • 100 Ω (MIN)

  • 1 kΩ (DEF)

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for 4-wire resistance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

MEAS:FRES?

Typical Response: +1.32130000E+04

The following command configures the instrument for 4-wire resistance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 kΩ range is selected with resolution set to 3.00E-5.

MEAS:FRES? 1000,3.0e-5

Typical Response: +4.27150000E+02

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:RESistance?

MEASure[:PRIMary]:RESistance?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:RESistance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all resistance measurement parameters and trigger parameters to their default values. Then, it configures the instrument for 2-wire resistance measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in ohms:

  • 100 Ω (MIN)

  • 1 kΩ (DEF)

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for 2-wire resistance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

MEAS:RES?

Typical Response: +1.32130000E+04

The following command configures the instrument for 2-wire resistance measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 kΩ range is selected with resolution set to 3.00E-5.

MEAS:RES? 1000,3.0e-5

Typical Response: +4.27150000E+02

See Also

CONFigure[:PRIMary]?

FETCh?

READ?


MEASure:TEMPerature?

MEASure[:PRIMary]:TEMPerature?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure[:PRIMary]:TEMPerature? [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]

Description

First, this command resets all temperature measurement parameters and trigger parameters to their default values. Then, it configures the instrument for temperature measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name | Type | Range of Values |  | Default Value
<probe_type> | Discrete | {THERmistor} |  | Required parameter: DEF sets THER
<type> | Discrete | For THER: | {5000} | Required parameter: DEF sets 5000
<resolution> | Numeric | Desired resolution in the currently selected units (°C or °F) |  | 3½ digits

Remarks

  • For temperature measurements, the instrument internally selects the range−you cannot select the range to be used.

  • For temperature measurements, the resolution is fixed at 3½ digits.

  • To change temperature units, use the UNIT:TEMPerature command.

  • For thermistor measurements, the instrument autoranges to the correct range for the transducer resistance measurement.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for 5 kΩ thermistor measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. This 2-wire measurement is made with 0.1 °C resolution (assumes default temperature units).

MEAS:TEMP? THER,5000,1,0.1

Typical Response: +2.47150000E+01

See Also

CONFigure[:PRIMary]?

UNIT:TEMPerature

FETCh?

READ?


MEASure:SECondary[:VOLTage][:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:SECondary[:VOLTage][:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all secondary DC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC voltage measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 1000 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Autoranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for DC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

MEAS:SEC:VOLT:DC?

Typical Response: +1.86850000E-03

The following command configures the instrument for DC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 V range is selected with resolution set to 3.00E-5.

MEAS:SEC:VOLT:DC? 1,3.0e-5

Typical Response: +4.27150000E-03

See Also

CONFigure:SECondary?

FETCh?

READ?


MEASure:SECondary[:VOLTage]:AC?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:SECondary[:VOLTage]:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all secondary AC voltage measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC voltage measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V (DEF)

  • 100 V

  • 750 V (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Autoranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for AC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5½ digits) are used for the measurement.

MEAS:SEC:VOLT:AC?

Typical Response: +1.86850000E-03

The following command configures the instrument for AC voltage measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 V range is selected.

MEAS:SEC:VOLT:AC? 1

Typical Response: +4.27150000E-03

See Also

CONFigure:SECondary?

FETCh?

READ?


MEASure:SECondary:CURRent:AC?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:SECondary:CURRent:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all secondary AC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for AC current measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in amps:

  • 10 mA (MIN)

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Autoranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For fastest measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for AC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution are used for the measurement.

MEAS:SEC:CURR:AC?

Typical Response: +8.54530000E-02

See Also

CONFigure:SECondary?

FETCh?

READ?


MEASure:SECondary:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:SECondary:CURRent[:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all secondary DC current measurement parameters and trigger parameters to their default values. Then, it configures the instrument for DC current measurements and immediately triggers a measurement. The reading is sent directly to the instrument output buffer.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in amps:

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA (DEF)

  • 1 A

  • 10 A (MAX)

  • Auto range (AUTO)

Auto range (AUTO)

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • You can allow the instrument to automatically select the measurement range using auto ranging or you can select a fixed range using manual ranging. Auto ranging is convenient because the instrument decides which range to use for each measurement based on the input signal. For faster measurements, use manual ranging on each measurement (some additional time is required for auto ranging since the instrument has to make a range selection).

  • If you select auto ranging (by specifying "AUTO" or "DEF"), an error will be generated if you specify a discrete value for the <resolution> parameter. When auto ranging is combined with a discrete resolution, the instrument cannot accurately resolve the integration time (especially if the input signal is continuously changing). If your application requires auto ranging, be sure to specify "DEF" for the <resolution> parameter or omit the parameter from the command.

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for DC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The default range (auto range) and resolution (5 1/2 digits) are used for the measurement.

MEAS:SEC:CURR:DC?

Typical Response: +8.54530000E-03

The following command configures the instrument for DC current measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer. The 1 A range is selected with resolution set to 3.00E-5.

MEAS:SEC:CURR:DC? 1,3.0e-5

Typical Response: +4.27150000E-02

See Also

CONFigure:SECondary?

FETCh?

READ?


MEASure:SECondary:FREQuency?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEASure:SECondary:FREQuency? [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Description

First, this command resets all secondary frequency measurement parameters and trigger parameters to their default values. Then, it configures the instrument for frequency measurements and immediately triggers a measurement. The results are sent directly to the instrument output buffer.

Parameters

Name | Type | Range of Values | Default Value
<range> | Numeric | Approximate frequency of the input signal in hertz, between 1 Hz and 1 MHz. MIN = 1 Hz DEF = 1 Hz MAX = 1 MHz | 1 Hz
<resolution> | Numeric | Desired resolution in hertz. | 5½ digits

Remarks

  • Frequency is measured on AC voltage signals. Thus, the proper AC voltage range should be set first using the [SENSe:]SECondary:FREQuency:VOLTage:RANGe command. The voltage range should be 0.1 volts or greater for more accurate frequency measurements.

  • The <range> parameter is required only to specify the measurement resolution parameter. Therefore, it is not necessary to send a new command for each new frequency to be measured.

  • With no signal applied "0" is returned.

  • If the TRIGger:SOURce is set to BUS, the MEASure? command overwrites the BUS trigger (sets it to IMMediate), triggers the DMM and returns a measurement.

  • For the available measurement functions in dual display mode, refer to the Keysight 34450A User Guide.

Return Format

The command returns a single reading.

Examples

The following command configures the instrument for frequency measurements, triggers the instrument to take a reading, and then transfers the reading to the instrument output buffer.

MEAS:SEC:FREQ?

Typical Response: +1.32130000E+03

See Also

CONFigure:SECondary?

FETCh?

READ?

[SENSe:]SECondary:FREQuency:VOLTage:RANGe


MEMory Subsystem Introduction

Command Summary

MEMory:STATe:RECall:AUTO

MEMory:STATe:RECall:AUTO?

MEMory:STATe:STORe

MEMory:STATe:STORe?


MEMory:STATe:RECall:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEMory:STATe:RECall:AUTO <mode>

MEMory:STATe:RECall:AUTO?

Description

This command disables or enables the automatic recall of the power-down state (state 0) when power is turned on. Select "ON" to automatically recall the power-down state (location 0) when power is turned on. Select "OFF" to issue a Factory Reset (and state 0 is not automatically recalled) when power is turned on.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • With the *SAV command, you can use location 0 to store a fifth instrument state. However, keep in mind that location 0 is automatically overwritten with the power-down state when power is cycled.

  • When shipped from the factory, storage locations 1 through 5 are empty and the instrument is configured to NOT automatically recall the power-down state (location 0) when power is restored.

  • A Factory Reset (*RST command) does not affect the value of <mode>.

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command enables automatic recall of the power-down state.

MEM:STAT:REC:AUTO ON

The following query returns the automatic recall setting.

MEM:STAT:REC:AUTO?

Typical Response: 0

See Also

*SAV


MEMory:STATe:STORe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MEMory:STATe:STORe <mode>

MEMory:STATe:STORe?

Description

This command disables or enables instrument state storage.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • When shipped from the factory, storage locations 1 through 5 are empty and the instrument is configured to NOT automatically recall the power-down state (location 0) when power is restored.

  • A Factory Reset (*RST command) does not affect the value of <mode>.

  • If the setting is disabled, sending *SAV <value> will result an error in error queue (+531)

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables instrument state storage.

MEM:STAT:STOR OFF

The following query returns the state storage setting.

MEM:STAT:STOR?

Typical Response: 0


MEMory Subsystem Introduction

SAMPle Subsystem Introduction

Command Summary

SAMPle:TIMer

SAMPle:TIMer?


MEMory:STATe:RECall:AUTO

SAMPle:TIMer

Syntax | Description | Parameters | Remarks | Return Format

Syntax

SAMPle:TIMer {<interval>|MIN|MAX}

SAMPle:TIMer?

Description

This command sets a sample interval for timed sampling when the sample count is greater than one.
1s to ~3600s
MIN = 5ms, (depend on function and resolution set)
MAX = ~3600 seconds (100us steps)

Parameters

Name | Type | Range of Values | Default Value
<interval> |  | 1s to 3600s | This is a required parameter

Remarks

  • MIN = 5ms, (depend on function and resolution set)
  • MAX = ~3600 seconds (100us steps)

Return Format

The command returns the sample interval in seconds.


SENSe Subsystem Introduction

Command Summary

AC Voltage

Primary Measurements

[SENSe:][PRIMary:]VOLTage:AC:RANGe

[SENSe:][PRIMary:]VOLTage:AC:RANGe?

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage:AC:RESolution

[SENSe:][PRIMary:]VOLTage:AC:RESolution?

Secondary Measurements

[SENSe:]SECondary:VOLTage:AC:RANGe

[SENSe:]SECondary:VOLTage:AC:RANGe?

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO?

[SENSe:]SECondary:VOLTage:AC:RESolution

[SENSe:]SECondary:VOLTage:AC:RESolution?

DC Voltage

Primary Measurements

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe?

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution?

Secondary Measurements

[SENSe:]SECondary:VOLTage[:DC]:RANGe

[SENSe:]SECondary:VOLTage[:DC]:RANGe?

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO?

[SENSe:]SECondary:VOLTage[:DC]:RESolution

[SENSe:]SECondary:VOLTage[:DC]:RESolution?

AC Current

Primary Measurements

[SENSe:][PRIMary:]CURRent:AC:RANGe

[SENSe:][PRIMary:]CURRent:AC:RANGe?

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent:AC:RESolution

[SENSe:][PRIMary:]CURRent:AC:RESolution?

Secondary Measurements

[SENSe:]SECondary:CURRent:AC:RANGe

[SENSe:]SECondary:CURRent:AC:RANGe?

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO?

[SENSe:]SECondary:CURRent:AC:RESolution

[SENSe:]SECondary:CURRent:AC:RESolution?

DC Current

Primary Measurements

[SENSe:][PRIMary:]CURRent[:DC]:RANGe

[SENSe:][PRIMary:]CURRent[:DC]:RANGe?

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent[:DC]:RESolution

[SENSe:][PRIMary:]CURRent[:DC]:RESolution?

Secondary Measurements

[SENSe:]SECondary:CURRent[:DC]:RANGe

[SENSe:]SECondary:CURRent[:DC]:RANGe?

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO?

[SENSe:]SECondary:CURRent[:DC]:RESolution

[SENSe:]SECondary:CURRent[:DC]:RESolution?

2-Wire Resistance

Primary Measurements

[SENSe:][PRIMary:]RESistance:OCOMpensated

[SENSe:][PRIMary:]RESistance:OCOMpensated?

[SENSe:][PRIMary:]RESistance:RANGe

[SENSe:][PRIMary:]RESistance:RANGe?

[SENSe:][PRIMary:]RESistance:RANGe:AUTO

[SENSe:][PRIMary:]RESistance:RANGe:AUTO?

[SENSe:][PRIMary:]RESistance:RESolution

[SENSe:][PRIMary:]RESistance:RESolution?

4-Wire Resistance

Primary Measurements

[SENSe:][PRIMary:]FRESistance:OCOMpensated

[SENSe:][PRIMary:]FRESistance:OCOMpensated?

[SENSe:][PRIMary:]FRESistance:RANGe

[SENSe:][PRIMary:]FRESistance:RANGe?

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO?

[SENSe:][PRIMary:]FRESistance:RESolution

[SENSe:][PRIMary:]FRESistance:RESolution?

Impedance

Primary Measurements

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO?

Frequency

Primary Measurements

[SENSe:][PRIMary:]FREQuency:APERture

[SENSe:][PRIMary:]FREQuency:APERture?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO?

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe?

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO?

Secondary Measurements

[SENSe:]SECondary:FREQuency:APERture

[SENSe:]SECondary:FREQuency:APERture?

[SENSe:]SECondary:FREQuency:VOLTage:RANGe

[SENSe:]SECondary:FREQuency:VOLTage:RANGe?

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO?

[SENSe:]SECondary:FREQuency:CURRent:RANGe

[SENSe:]SECondary:FREQuency:CURRent:RANGe?

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO?

[SENSe:]SECondary:FREQuency:APERture

[SENSe:]SECondary:FREQuency:APERture?

Temperature

Primary Measurements

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE?

Capacitance

Primary Measurements

[SENSe:][PRIMary:]CAPacitance:RANGe

[SENSe:][PRIMary:]CAPacitance:RANGe?

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO?

Miscellaneous

Primary Measurements

[SENSe:][PRIMary:]FUNCtion

[SENSe:][PRIMary:]FUNCtion?

Secondary Measurements

[SENSe:]SECondary:FUNCtion

[SENSe:]SECondary:FUNCtion?


[SENSe:]CAPacitance:RANGe

[SENSe:][PRIMary:]CAPacitance:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CAPacitance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CAPacitance:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for capacitance measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Numeric

Desired range in F (farads):

  • 1 nF (MIN)

  • 10 nF

  • 100 nF

  • 1 µF

  • 10 µF

  • 100 µF

  • 1 mF

  • 10 mF (MAX)

This is a required parameter.

DEF sets 1 µF

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument selects auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E-02".

Examples

The following command selects the 1 nF range.

CAP:RANG 1 nF    or    CAP:RANG 0.000000001     or     CAP:RANG 1.0E-9

The following query returns the selected range.

CAP:RANG?

Typical Response: +1.00000000E-09

See Also

CONFigure[:PRIMary]:CAPacitance

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO


[SENSe:]CAPacitance:RANGe:AUTO

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO <mode>

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO?

Description

This command disables or enables auto ranging for capacitance measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]CAPacitance:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables autoranging.

CAP:RANG:AUTO OFF

The following query returns the autoranging settings.

CAP:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:CAPacitance

[SENSe:][PRIMary:]CAPacitance:RANGe


[SENSe:]FUNCtion

[SENSe:][PRIMary:]FUNCtion

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FUNCtion "<function>"

[SENSe:][PRIMary:]FUNCtion?

Description

This command selects the primary measurement function (all function-related measurement attributes are retained).

Parameters

Name

Type

Range of Values

Default Value

<function>

Discrete

Desired function enclosed in quotes:

  • CAPacitance

  • CONTinuity

  • CURRent:AC

  • CURRent[:DC]

  • DIODe

  • FREQuency

  • RESistance

  • FRESistance

  • TEMPerature

  • VOLTage:AC

  • VOLTage[:DC]

This is a required parameter

Remarks

  • If you change the measurement function, all measurement attributes of the previous function (range, resolution, etc.) are remembered. If you return to the original function, all previously-defined measurement attributes will be restored.

  • This command has no default value. However, the instrument defaults to DC volts after a Factory Reset (*RST command).

Return Format

The query command returns an ASCII string enclosed in double quotes. The short form of the function name is always returned (e.g., "CURR:AC", "FREQ", "TEMP").

Examples

The following commands select the AC voltage function (double or single quotes are allowed).

FUNC "VOLT:AC" or FUNC 'VOLT:AC'

The following query returns the function selected (the quotes are also returned).

FUNC?

Typical Response: "VOLT:AC"

See Also

CONFigure[:PRIMary]?


[SENSe:]CURRent:AC:RANGe

[SENSe:][PRIMary:]CURRent:AC:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent:AC:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for primary AC current measurements.

Parameters

Name | Type | Range of Values | Default Value
<range> | Discrete | Desired range in amps: 10 mA (MIN) 100 mA 1 A 10 A (MAX) | This is a required parameter. DEF sets 100 mA

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument selects auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E-01".

Examples

The following command selects the 100 mA range.

CURR:AC:RANG 0.1

The following query returns the selected range.

CURR:AC:RANG?

Typical Response: +1.00000000E-01

See Also

CONFigure[:PRIMary]:CURRent:AC

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO


[SENSe:]CURRent:AC:RANGe:AUTO

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO <mode>

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO?

Description

This command disables or enables auto ranging for primary AC current measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]CURRent:AC:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

CURR:AC:RANG:AUTO OFF

The following query returns the auto ranging settings.

CURR:AC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:CURRent:AC

[SENSe:][PRIMary:]CURRent:AC:RANGe


[SENSe:]CURRent:AC:RESolution

[SENSe:][PRIMary:]CURRent:AC:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent:AC:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for primary AC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

CURR:AC:RES 3.0e-5

The following query returns the resolution selected.

CURR:AC:RES?

Typical Response: 3.0e-5

See Also

CONFigure[:PRIMary]:CURRent:AC


[SENSe:]CURRent[:DC]:RANGe

[SENSe:][PRIMary:]CURRent[:DC]:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent[:DC]:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for primary DC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in amps:

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA

  • 1 A

  • 10 A (MAX)

This is a required parameter.

DEF sets 100 mA

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E-01".

Examples

The following command selects the 100 mA range.

CURR:DC:RANG 0.1

The following query returns the range selected.

CURR:DC:RANG?

Typical Response: +1.00000000E-01

See Also

CONFigure[:PRIMary]:CURRent[:DC]

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO


[SENSe:]CURRent[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO <mode>

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO?

Description

This command disables or enables auto ranging for primary DC current measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | Auto range ON

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]CURRent[:DC]:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

CURR:DC:RANG:AUTO OFF

The following query returns the auto ranging state.

CURR:DC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:CURRent[:DC]

[SENSe:][PRIMary:]CURRent[:DC]:RANGe


[SENSe:]CURRent[:DC]:RESolution

[SENSe:][PRIMary:]CURRent[:DC]:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]CURRent[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent[:DC]:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for primary DC current measurements. Specify the resolution in the same units as the selected measurement function, not in number of digits.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

CURR:DC:RES 3.0e-5

The following query returns the resolution selected.

CURR:DC:RES?

Typical Response: 3.00E-5

See Also

CONFigure[:PRIMary]:CURRent[:DC]


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:APERture

Syntax | Description | Parameters | Return Format | Example

Syntax

[SENSe:][PRIMary:]FREQuency:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:APERture? [{MIN|MAX}]

Description

This command selects the aperture time (also called gate time) for frequency measurements.

Parameters

Name | Type | Range of Values | Default Value
<second> | Discrete | Desired aperture in seconds: MIN = 100 ms MAX = 1 s DEF = 1 s | This is a required parameter. DEF sets 1 s

Remarks

  • This command sets the aperture for frequency measurements.
  • The instrument sets the aperture time to one second after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the aperture time in the form "+1.00000000E-01".

Example

The following command sets the aperture to 100 ms.

FREQ:APER 0.1

The following query returns the aperture selected.

FREQ:APER?

Typical Response: +1.00000000E-01

See Also

CONFigure[:PRIMary]:FREQuency


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe? [{MIN|MAX}]

Description

This command selects the voltage range for primary frequency measurements.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<voltage_range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 750 V (MAX)

This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the voltage range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range for frequency measurements.

FREQ:VOLT:RANG 10

The following query returns the voltage range selected.

FREQ:VOLT:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure[:PRIMary]:FREQuency

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO


[SENSe:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO <mode>

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO?

Description

This command disables or enables voltage auto ranging for primary frequency measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input AC voltage detected.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Autorange thresholds:

    Down range at:

    <10% of range (AC voltage)

    Up range at:

    >120% of range (AC voltage)

  • With auto ranging enabled, the instrument selects the appropriate voltage range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]FREQuency:VOLTage:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

FREQ:VOLT:RANG:AUTO OFF

The following query returns the auto ranging setting.

FREQ:VOLT:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:FREQuency

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe? [{MIN|MAX}]

Description

This command selects the current range for frequency on AC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in amps:

  • 10 mA (MIN)

  • 100 mA

  • 1 A

  • 10 A (MAX)

This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable the autoranging.
  • The instrument enables autoranging after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the current range in the form "+1.00000000E-01".

Examples

The following command selects the 10 mA current range for frequency measurements.

FREQ:CURR:RANG 10e-3

The following query returns the current range selected.

FREQ:CURR:RANG?

Typical Response: +1.00000000E-02

See Also

CONFigure[:PRIMary]:FREQuency


[SENSe:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO <mode>

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO?

Description

This command disables or enables current auto ranging for primary frequency measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input AC current detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Selecting a discrete range (see [SENSe:][PRIMary:]FREQuency:CURRent:RANGe command) will disable auto ranging.
  • The instrument enables auto ranging after a Factory Reset (*RST command).
  • With auto ranging enabled, the instrument selects the appropriate voltage range based on the input signal detected.
  • Autorange thresholds:
    - Lower range at: <10% of range (AC current)
    - Upper range at: >120% of range (AC current)

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

FREQ:CURR:RANG:AUTO OFF

The following query returns the auto ranging setting.

FREQ:CURR:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:FREQuency


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]FRESistance:OCOMpensated

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FRESistance:OCOMpensated {<mode>|OFF|0|ON|1}

[SENSe:][PRIMary:]FRESistance:OCOMpensated?

Description

This command enables or disables offset compensation for resistance measurements. Offset compensation removes the effects of small dc voltages in circuit being measured. This technique involves taking the difference between two resistance measurements, with the current source set to normal value and a lower value respectively.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | OFF|0|ON|1 | OFF|0

Remarks

  • This command affects both the 2-wire and 4-wire resistance measurements. All FRESistance and RESistance commands affect the equivalent settings for all resistance measurements.
  • Applies only to resistance measurements on the 100Ω, 1 kΩ, and 10 kΩ ranges.
  • The instrument disables offset compensation after a Factory Reset (*RST command) or an Instruments Preset (SYSTem:PRESet command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command enables offset compensation.

FRES:OCOM ON

The following query returns the offset compensation setting.

FRES:OCOM?

Typical Response: 1


[SENSe:]RESistance:RANGe

[SENSe:][PRIMary:]FRESistance:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FRESistance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FRESistance:RANGe?

Description

This command selects the measurement range for 4-wire resistance measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in ohms:

  • 100 Ω (MIN)

  • 1 kΩ

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ (MAX)

This is a required parameter.

DEF sets 1 kΩ

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E+03".

Examples

The following command selects the 10 kΩ range.

FRES:RANG 10E+3

The following query returns the range selected.

FRES:RANG?

Typical Response: +1.00000000E+04

See Also

CONFigure[:PRIMary]:FRESistance

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO


[SENSe:]RESistance:RANGe:AUTO

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO <mode>

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO?

Description

This command disables or enables auto ranging for 4-wire resistance measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

Down range at: | <10% of range
Up range at: | >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

FRES:RANG:AUTO OFF

The following query returns the auto ranging settings.

FRES:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:FRESistance

[SENSe:][PRIMary:]FRESistance:RANGe


[SENSe:]RESistance:RESolution

[SENSe:][PRIMary:]FRESistance:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]FRESistance:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FRESistance:RESolution?

Description

This command selects the measurement resolution for 4-wire resistance measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

FRES:RES 3.0e-5

The following query returns the resolution selected.

FRES:RES?

Typical Response: 3.00E-5

See Also

CONFigure[:PRIMary]:FRESistance


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]RESistance:OCOMpensated

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]RESistance:OCOMpensated {<mode>|OFF|0|ON|1}

[SENSe:][PRIMary:]RESistance:OCOMpensated?

Description

This command enables or disables offset compensation for resistance measurements. Offset compensation removes the effects of small dc voltages in circuit being measured. This technique involves taking the difference between two resistance measurements, with the current source set to normal value and a lower value respectively.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | OFF|0|ON|1 | OFF|0

Remarks

  • This command affects both the 2-wire and 4-wire resistance measurements. All FRESistance and RESistance commands affect the equivalent settings for all resistance measurements.
  • Applies only to resistance measurements on the 100Ω, 1 kΩ, and 10 kΩ ranges.
  • The instrument disables offset compensation after a Factory Reset (*RST command) or an Instruments Preset (SYSTem:PRESet command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command enables offset compensation.

RES:OCOM ON

The following query returns the offset compensation setting.

RES:OCOM?

Typical Response: 1


[SENSe:]RESistance:RANGe

[SENSe:][PRIMary:]RESistance:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]RESistance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]RESistance:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for 2-wire resistance measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in ohms:

  • 100 Ω (MIN)

  • 1 kΩ

  • 10 kΩ

  • 100 kΩ

  • 1 MΩ

  • 10 MΩ

  • 100 MΩ (MAX)

This is a required parameter.

DEF sets 1 kΩ

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E+03".

Examples

The following command selects the 10 kΩ range.

RES:RANG 10E+3

The following query returns the range selected.

RES:RANG?

Typical Response: +1.00000000E+04

See Also

CONFigure[:PRIMary]:RESistance

[SENSe:][PRIMary:]RESistance:RANGe:AUTO


[SENSe:]RESistance:RANGe:AUTO

[SENSe:][PRIMary:]RESistance:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]RESistance:RANGe:AUTO <mode>

[SENSe:][PRIMary:]RESistance:RANGe:AUTO?

Description

This command disables or enables auto ranging for 2-wire resistance measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

Down range at: | <10% of range
Up range at: | >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

RES:RANG:AUTO OFF

The following query returns the auto ranging settings.

RES:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary]:RESistance

[SENSe:][PRIMary:]RESistance:RANGe


[SENSe:]RESistance:RESolution

[SENSe:][PRIMary:]RESistance:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]RESistance:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]RESistance:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for 2-wire resistance measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

RES:RES 3.0e-5

The following query returns the resolution selected.

RES:RES?

Typical Response: 3.00E-5

See Also

CONFigure[:PRIMary]:RESistance


[SENSe:]TEMPerature:TRANsducer:THERmistor:TYPE

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE <type>

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE?

Description

This command selects the thermistor type for 2-wire temperature measurements.

Parameters

Name | Type | Range of Values | Default Value
<type> | Discrete | {5000} | 5000

Remarks

  • The instrument supports standard 5 kΩ thermistors.

  • The instrument sets the thermistor type to "5000" after a Factory Reset (*RST command).

Return Format

The query command returns "+5000".

Examples

The following command selects a 5 kΩ thermistor.

TEMP:TRAN:THER:TYPE 5000

The following query returns the thermistor type selection.

TEMP:TRAN:THER:TYPE?

Typical Response: +5000

See Also

CONFigure[:PRIMary]:TEMPerature


[SENSe:]VOLTage:AC:RANGe

[SENSe:][PRIMary:]VOLTage:AC:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage:AC:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for primary AC voltage measurements.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 750 V (MAX)

 This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface..

Return Format

The query command returns the range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range.

VOLT:AC:RANG 10

The following query returns the range selected.

VOLT:AC:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure[:PRIMary][:VOLTage]:AC

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO


[SENSe:]VOLTage:AC:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO <mode>

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO?

Description

This command disables or enables auto ranging for primary AC voltage measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]VOLTage:AC:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

VOLT:AC:RANG:AUTO OFF

The following query returns the auto ranging setting.

VOLT:AC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary][:VOLTage]:AC

[SENSe:][PRIMary:]VOLTage:AC:RANGe


[SENSe:]VOLTage:AC:RESolution

[SENSe:][PRIMary:]VOLTage:AC:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage:AC:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for primary AC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5 1/2 digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

VOLT:AC:RES 3.0e-5

The following query returns the resolution selected.

VOLT:AC:RES?

Typical Response: 3.00E-5

See Also

CONFigure[:PRIMary][:VOLTage]:AC


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO

Syntax | Description | Remarks

Syntax

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO <mode>

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO?

Description

This command disables or enables the automatic input impedance mode for dc voltage measurements. Normally, the instrument's input resistance is fixed at 10 MΩ for all dc voltage measurements to minimize noise pickup. In the automatic input impedance mode ("AUTO ON"), the input impedance is automatically varied according to range. For the 100 mV, 1 V, and 10 V ranges the input impedance is automatically set to "HI-Z" (>10 GΩ) to reduce the effects of measurement loading errors on these lower ranges. For the 100 V and 1000 V ranges, the input impedance remains at 10 MΩ.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • This command affects dc voltage measurements only.

  • Normally, the instrument's input resistance is fixed at 10 MΩ for all dc voltage measurements to minimize noise pickup.

  • In the default mode ("AUTO OFF"), the input impedance for dc voltage measurements is fixed at 10 MΩ for all ranges.

  • In the automatic input impedance mode ("AUTO ON"), the input impedance for dc voltage measurements is automatically selected according to range. The impedance is set to "HI-Z" (>10 GΩ) for the 100 mV, 1 V, and 10 V ranges. The 100 V and 1000 V ranges remain at a 10 MΩ input impedance.

  • This setting is reset to the default (fixed, 10 MΩ) by the *RST and SYSTem:PRESet commands.

Return Format

The query returns the current state of the automatic input impedance mode: "0" (OFF) or "1" (ON).

Examples

The following command disables the automatic input impedance mode. All dc voltage measurements are made with a fixed, 10 MΩ input impedance.

VOLT:IMP:AUTO OFF

The following query returns the current state of the automatic input impedance mode.

VOLT:IMP:AUTO?

Typical Response: 0


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for primary DC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 1000 V (MAX)

This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • The instrument is set to 1000 V, with auto ranging enabled, after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range.

VOLT:DC:RANG 10

The following query returns the range selected.

VOLT:DC:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure[:PRIMary][:VOLTage][:DC]

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO


[SENSe:]VOLTage[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO <mode>

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO?

Description

This command disables or enables auto ranging for primary DC voltage measurements. Autoranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:][PRIMary:]VOLTage[:DC]:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables autoranging.

VOLT:DC:RANG:AUTO OFF

The following query returns the autoranging setting.

VOLT:DC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:PRIMary][:VOLTage][:DC]

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe


[SENSe:]VOLTage[:DC]:RESolution

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for primary DC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

VOLT:DC:RES 3.0e-5

The following query returns the resolution selected.

VOLT:DC:RES?

Typical Response: 3.00E-5

See Also

CONFigure[:PRIMary][:VOLTage][:DC]


[SENSe:]FUNCtion

[SENSe:]SECondary:FUNCtion

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:FUNCtion "<function>"

[SENSe:]SECondary:FUNCtion?

Description

This command selects the secondary measurement function (all function-related measurement attributes are retained).

Parameters

Name

Type

Range of Values

Default Value

<function>

Discrete

Desired function enclosed in quotes:

  • CURRent:AC

  • CURRent[:DC]

  • FREQuency

  • VOLTage:AC

  • VOLTage[:DC]

This is a required parameter

Remarks

  • If you change the measurement function, all measurement attributes of the previous function (range, resolution, etc.) are remembered. If you return to the original function, all previously-defined measurement attributes will be restored.

  • This command has no default value. However, the instrument defaults to DC volts after a Factory Reset (*RST command).

Return Format

The query command returns an ASCII string enclosed in double quotes. The short form of the function name is always returned (e.g., "CURR:AC", "FREQ", "TEMP").

Examples

The following commands select the AC voltage function (double or single quotes are allowed).

SEC:FUNC "VOLT:AC" or SEC:FUNC 'VOLT:AC'

The following query returns the function selected (the quotes are also returned).

SEC:FUNC?

Typical Response: "VOLT:AC"

See Also

CONFigure:SECondary?


[SENSe:]CURRent:AC:RANGe

[SENSe:]SECondary:CURRent:AC:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent:AC:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for secondary AC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in amps:

  • 10 mA (MIN)

  • 100 mA

  • 1 A

  • 10 A (MAX)

This is a required parameter.

DEF sets 100 mA

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument selects auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E-01".

Examples

The following command selects the 100 mA range.

SEC:CURR:AC:RANG 0.1

The following query returns the selected range.

SEC:CURR:AC:RANG?

Typical Response: +1.00000000E-01

See Also

CONFigure:SECondary:CURRent:AC

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO


[SENSe:]CURRent:AC:RANGe:AUTO

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO <mode>

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO?

Description

This command disables or enables auto ranging for secondary AC current measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:]SECondary:CURRent:AC:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:CURR:AC:RANG:AUTO OFF

The following query returns the auto ranging settings.

SEC:CURR:AC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure:SECondary:CURRent:AC

[SENSe:]SECondary:CURRent:AC:RANGe


[SENSe:]CURRent:AC:RESolution

[SENSe:]SECondary:CURRent:AC:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent:AC:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for secondary AC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

SEC:CURR:AC:RES 3.0e-5

The following query returns the resolution selected.

SEC:CURR:AC:RES?

Typical Response: 3.00E-5

See Also

CONFigure:SECondary:CURRent:AC


[SENSe:]CURRent[:DC]:RANGe

[SENSe:]SECondary:CURRent[:DC]:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent[:DC]:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for secondary DC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in amps:

  • 100 µA (MIN)

  • 1 mA

  • 10 mA

  • 100 mA

  • 1 A

  • 10 A (MAX)

This is a required parameter.

DEF sets 100 mA

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E-01".

Examples

The following command selects the 100 mA range.

SEC:CURR:DC:RANG 0.1

The following query returns the range selected.

SEC:CURR:DC:RANG?

Typical Response: +1.00000000E-01

See Also

CONFigure:SECondary:CURRent[:DC]

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO


[SENSe:]CURRent[:DC]:RANGe:AUTO

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO <mode>

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO?

Description

This command disables or enables auto ranging for secondary DC current measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:]SECondary:CURRent[:DC]:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:CURR:DC:RANG:AUTO OFF

The following query returns the auto ranging state.

SEC:CURR:DC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure:SECondary:CURRent[:DC]

[SENSe:]SECondary:CURRent[:DC]:RANGe


[SENSe:]CURRent[:DC]:RESolution

[SENSe:]SECondary:CURRent[:DC]:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:CURRent[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent[:DC]:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for secondary DC current measurements. Specify the resolution in the same units as the selected measurement function, not in number of digits.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

SEC:CURR:DC:RES 3.0e-5

The following query returns the resolution selected.

SEC:CURR:DC:RES?

Typical Response: 3.00E-5

See Also

CONFigure:SECondary:CURRent[:DC]


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:]SECondary:FREQuency:APERture

Syntax | Description | Return Format | Example

Syntax

[SENSe:]SECondary:FREQuency:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:APERture? [{MIN|MAX}]

Description

This command selects the aperture time (also called gate time) for secondary frequency measurements.

Parameters

Name | Type | Range of Values | Default Value
<second> | Discrete | Desired aperture in seconds: MIN = 100 ms MAX = 1 s DEF = 1 s | This is a required parameter. DEF sets 1 s

Remarks

  • This command sets the aperture for frequency measurements.
  • The instrument sets the aperture time to one second after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the aperture time in the form "+1.00000000E-01".

Example

The following command sets the aperture to 100 ms.

SEC:FREQ:APER 0.1

The following query returns the aperture selected.

SEC:FREQ:APER?

Typical Response: +1.00000000E-01


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:]SECondary:FREQuency:VOLTage:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:FREQuency:VOLTage:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:VOLTage:RANGe? [{MIN|MAX}]

Description

This command selects the voltage range for secondary frequency measurements.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<voltage_range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 750 V (MAX)

This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "VAC Overload" from the front panel or "±9.9E+37" from the remote interface.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns the voltage range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range for frequency measurements.

SEC:FREQ:VOLT:RANG 10

The following query returns the voltage range selected.

SEC:FREQ:VOLT:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure:SECondary:FREQuency

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO


[SENSe:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO <mode>

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO?

Description

This command disables or enables voltage auto ranging for secondary frequency measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input AC voltage detected.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range (AC voltage)

    Up range at:

    >120% of range (AC voltage)

  • With auto ranging enabled, the instrument selects the appropriate voltage range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:]SECondary:FREQuency:VOLTage:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:FREQ:VOLT:RANG:AUTO OFF

The following query returns the auto ranging setting.

SEC:FREQ:VOLT:RANG:AUTO?

Typical Response: 0

See Also

CONFigure:SECondary:FREQuency y

[SENSe:]SECondary:FREQuency:VOLTage:RANGe


[SENSe:]FREQuency:VOLTage:RANGe

[SENSe:]SECondary:FREQuency:CURRent:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:FREQuency:CURRent:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:CURRent:RANGe? [{MIN|MAX}]

Description

This command selects the current range for frequency on AC current measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in amps:

  • 10 mA (MIN)

  • 100 mA

  • 1 A

  • 10 A (MAX)

This is a required parameter.

DEF sets 100 mA

Remarks

  • Selecting a discrete range will disable the autoranging.
  • The instrument enables autoranging after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the current range in the form "+1.00000000E-01".

Examples

The following command selects the 10mA current range for frequency measurements.

SEC:FREQ:CURR:RANG 10e-3

The following query returns the current range selected.

SEC:FREQ:CURR:RANG?

Typical Response: +1.00000000E-02

See Also

CONFigure[:SECondary]:FREQuency


[SENSe:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO <mode>

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO?

Description

This command selects the current range for frequency on AC current measurements.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Selecting a discrete range (see [SENSe:][PRIMary:]FREQuency:CURRent:RANGe command) will disable auto ranging.
  • The instrument enables auto ranging after a Factory Reset (*RST command).
  • With auto ranging enabled, the instrument selects the appropriate current range based on the input signal detected.
  • Auto range thresholds:
    - Lower range at: <10% of range (AC current)
    - Upper range at: >120% of range (AC current)

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:FREQ:CURR:RANG:AUTO OFF

The following query returns the auto ranging setting.

SEC:FREQ:CURR:RANG:AUTO?

Typical Response: 0

See Also

CONFigure[:SECondary]:FREQuency


[SENSe:]VOLTage:AC:RANGe

[SENSe:]SECondary:VOLTage:AC:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage:AC:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for secondary AC voltage measurements.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 750 V (MAX)

 This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: "OL" from the front panel or "±9.9E+37" from the remote interface.

Return Format

The query command returns the range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range.

SEC:VOLT:AC:RANG 10

The following query returns the range selected.

SEC:VOLT:AC:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure:SECondary[:VOLTage]:AC

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO


[SENSe:]VOLTage:AC:RANGe:AUTO

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO <mode>

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO?

Description

This command disables or enables auto ranging for secondary AC voltage measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

The SAFETY LIMIT on the front HI/LO input terminals is 750 VAC (rms) for a sinusoidal waveform or 1000 V (peak) for any other waveform. Connections to AC MAINS are further limited to CAT II (300V). See the "Safety Information" section in the Keysight 34450A User's Guide for a complete discussion of the safety features, and the safe operation of this instrument.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:]SECondary:VOLTage:AC:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:VOLT:AC:RANG:AUTO OFF

The following query returns the auto ranging setting.

SEC:VOLT:AC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure:SECondary[:VOLTage]:AC

[SENSe:]SECondary:VOLTage:AC:RANGe


[SENSe:]VOLTage:AC:RESolution

[SENSe:]SECondary:VOLTage:AC:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage:AC:RESolution?

Description

This command selects the measurement resolution for secondary AC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5"

Examples

The following command sets the measurement resolution to 3.00E-5.

SEC:VOLT:AC:RES 3.0e-5

The following query returns the resolution selected.

SEC:VOLT:AC:RES?

Typical Response: 3.00E-5

See Also

CONFigure:SECondary[:VOLTage]:AC


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:]SECondary:VOLTage[:DC]:IMPedance:AUTO

Syntax | Description | Remarks

Syntax

[SENSe:]SECondary:VOLTage[:DC]:IMPedance:AUTO <mode>

[SENSe:]SECondary:VOLTage[:DC]:IMPedance:AUTO?

Description

This command selects disables or enables the automatic input impedance mode for DC voltage measurements.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Normally, the instrument's input resistance is fixed at 10 MΩ for all dc voltage measurements to minimize noise pickup.

  • In the automatic input impedance mode ("AUTO ON"), the input impedance is automatically varied according to range.

  • For the 100 mV, 1 V, and 10 V ranges the input impedance is automatically set to "HI-Z" (>10 GΩ) to reduce the effects of measurement loading errors on these lower ranges.

  • For the 100 V and 1000 V ranges, the input impedance remains at 10 MΩ.

Return Format

The query returns the current state of the automatic input impedance mode: "0" (OFF) or "1" (ON).

Examples

The following command disables the automatic input impedance mode. All dc voltage measurements are made with a fixed, 10 MΩ input impedance.

SEC:VOLT:IMP:AUTO OFF

The following query returns the current state of the automatic input impedance mode.

SEC:VOLT:IMP:AUTO?

Typical Response: 0


[SENSe:]VOLTage[:DC]:RANGe

[SENSe:]SECondary:VOLTage[:DC]:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage[:DC]:RANGe? [{MIN|MAX}]

Description

This command selects the measurement range for secondary DC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<range>

Discrete

Desired range in volts:

  • 100 mV (MIN)

  • 1 V

  • 10 V

  • 100 V

  • 1000 V (MAX)

This is a required parameter.

DEF sets 10 V

Remarks

  • Selecting a discrete range will disable auto ranging.

  • If the input signal is greater than can be measured on the selected range (manual ranging), the instrument gives an overload indication: OL (positive overload) or -OL (negative overload) from the front panel or "±9.9E+37" from the remote interface.

  • The instrument is set to 1000 V, with auto ranging enabled, after a Factory Reset (*RST command).

Return Format

The query command returns the range in the form "+1.00000000E+01".

Examples

The following command selects the 10 volt range.

SEC:VOLT:DC:RANG 10

The following query returns the range selected.

SEC:VOLT:DC:RANG?

Typical Response: +1.00000000E+01

See Also

CONFigure:SECondary[:VOLTage][:DC]

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO


[SENSe:]VOLTage[:DC]:RANGe:AUTO

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO <mode>[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO?

Description

This command disables or enables auto ranging for secondary DC voltage measurements. Auto ranging is convenient because the instrument automatically selects the range for each measurement based on the input signal detected.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Auto range thresholds:

    Down range at:

    <10% of range

    Up range at:

    >120% of range

  • With auto ranging enabled, the instrument selects the appropriate range based on the input signal detected.

  • Selecting a discrete range (see [SENSe:]SECondary:VOLTage[:DC]:RANGe command) will disable auto ranging.

  • The instrument enables auto ranging after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables auto ranging.

SEC:VOLT:DC:RANG:AUTO OFF

The following query returns the auto ranging setting.

SEC:VOLT:DC:RANG:AUTO?

Typical Response: 0

See Also

CONFigure:SECondary[:VOLTage][:DC]

[SENSe:]SECondary:VOLTage[:DC]:RANGe


[SENSe:]VOLTage[:DC]:RESolution

[SENSe:]SECondary:VOLTage[:DC]:RESolution

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SENSe:]SECondary:VOLTage[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage[:DC]:RESolution? [{MIN|MAX}]

Description

This command selects the measurement resolution for secondary DC voltage measurements.

Parameters

Name

Type

Range of Values

Default Value

<resolution>

Numeric

  • 3.00E-5

  • 2.00E-5

  • 1.50E-6

1.50E-6 (5½ digits)

Remarks

  • For the <resolution> parameter, you can substitute MIN or MAX for a numeric value. MIN selects the smallest value accepted, which gives the highest resolution; MAX selects the largest value accepted, which gives the least resolution.

  • The instrument sets the resolution to 5½ digits after a Factory Reset (*RST command).

Return Format

The query command returns the resolution in the form "3.00E-5".

Examples

The following command sets the measurement resolution to 3.00E-5.

SEC:VOLT:DC:RES 3.0e-5

The following query returns the resolution selected.

SEC:VOLT:DC:RES?

Typical Response: 3.00E-5

See Also

CONFigure:SECondary[:VOLTage][:DC]


STATus Subsystem Introduction

Keysight 34450A Status System Diagram

Command Summary

*ESE

*ESE?

*ESR?

*PSC

*PSC?

*SRE

*SRE?

*STB?

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?


STATus:OPERation:CONDition?

Syntax | Description | Remarks | Return Format | Example

Syntax

STATus:OPERation:CONDition?

Description

This command queries the condition register for the Standard Operation Register group. This is a read-only register and the bits are not cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Remarks

  • The condition register bits reflect the current condition. If a condition goes away, the corresponding bit is cleared in the condition register.

  • The following table lists the bit definitions for the Standard Operation Register.

Bit Number |  | Decimal Value | Definition
0 | Calibration in Progress | 1 | Instrument is performing a calibration.
1-3 | Not Used | Not Used | "0" is returned.
4 | Measuring | 16 | Instrument is initiated, and is making, or about to make a measurement.
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6-7 | Not Used | Not Used | "0" is returned.
8 | Configuration Change | 256 | Instrument configuration has been changed, either from the front panel or from SCPI.
9-15 | Not Used | Not Used | "0" is returned.

Return Format

The command reads the condition register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 5 (decimal value = 32) and bit 8 (decimal value = 256) are set, this command will return "+288".

Example

The following command reads the condition register (bit 5 is set).

STAT:OPER:COND?

Typical Response: +32

See Also

STATus:OPERation:ENABle

STATus:OPERation[:EVENt]?


STATus:OPERation:ENABle

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:OPERation:ENABle <enable_value>

STATus:OPERation:ENABle?

Description

This command enables bits in the enable register for the Standard Operation Register group. The selected bits are then reported to the Status Byte.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | This is a required parameter

Remarks

  • The following table lists the bit definitions for the Standard Operation Register.

Bit Number |  | Decimal Value | Definition
0 | Calibration in Progress | 1 | Instrument is performing a calibration.
1-3 | Not Used | Not Used | "0" is returned.
4 | Measuring | 16 | Instrument is initiated, and is making, or about to make a measurement.
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6-7 | Not Used | Not Used | "0" is returned.
8 | Configuration Change | 256 | Instrument configuration has been changed, either from the front panel or from SCPI.
9-15 | Not Used | Not Used | "0" is returned.

  • Use the <enable_value> parameter to specify which bits will be reported to the Status Byte. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 5 (decimal value = 32) and bit 8 (decimal value = 256), the corresponding decimal value would be 288 (32 + 256).

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

  • The STATus:PRESet command will clear all bits in the enable register.

  • The *RST command has no effect on this register.

  • The *PSC command affects whether this register is cleared at power on.

Return Format

The query command reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 4 (decimal value = 16) and bit 8 (decimal value = 256) are enabled, the query command will return "+272".

Examples

The following command enables bit 5 (decimal value = 32) in the enable register.

STAT:OPER:ENAB 32

The following query returns which bits are enabled in the register.

STAT:OPER:ENAB?

Typical Response: +32

See Also

STATus:OPERation:CONDition?

STATus:OPERation[:EVENt]?

STATus:PRESet


STATus:OPERation[:EVENt]?

Syntax | Description | Remarks | Return Format | Example

Syntax

STATus:OPERation[:EVENt]?

Description

This command queries the event register for the Standard Operation Register group. This is a read-only register and the bits are cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Remarks

  • The following table lists the bit definitions for the Standard Operation Register.

Bit Number |  | Decimal Value | Definition
0 | Calibration in Progress | 1 | Instrument is performing a calibration.
1-3 | Not Used | Not Used | "0" is returned.
4 | Measuring | 16 | Instrument is initiated, and is making, or about to make a measurement.
5 | Waiting for Trigger | 32 | Instrument is waiting for a trigger.
6-7 | Not Used | Not Used | "0" is returned.
8 | Configuration Change | 256 | Instrument configuration has been changed, either from the front panel or from SCPI.
9-15 | Not Used | Not Used | "0" is returned.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

  • The *RST and *PSC commands have no effect on this register.

Return Format

The command reads the event register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 4 (decimal value = 16) and bit 8 (decimal value = 256) are set, this command will return "+272".

Example

The following command reads the event register (bit 8 is set).

STAT:OPER?

Typical Response: +256

See Also

STATus:OPERation:ENABle


STATus:PRESet

Syntax | Description | Remarks | Example

Syntax

STATus:PRESet

Description

This command clears all bits in the Questionable Data enable register and the Standard Operation enable register.

Remarks

  • See STATus Subsystem Introduction for an overview of the status system.

Example

The following command clears the enable register bits.

STAT:PRES

See Also

STATus Subsystem Introduction


STATus:QUEStionable:CONDition?

Syntax | Description | Remarks | Return Format | Example

Syntax

STATus:QUEStionable:CONDition?

Description

This command queries the condition register for the Questionable Data Register group. This is a read-only register and the bits are not cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Remarks

  • The condition register bits reflect the current condition. If a condition goes away, the corresponding bit is cleared in the condition register.

  • The following table lists the bit definitions for the condition register in the Questionable Data group.

Bit Number |  | Decimal Value | Definition
0 | Voltage Overload | 1 | Only reported as event. Returns "0". Read the Event Register.
1 | Current Overload | 2 | Only reported as event. Returns "0". Read the Event Register.
2-3 | Not Used | Not Used | "0" is returned.
4 | Temperature Overload | 16 | Only reported as event. Returns "0". Read the Event Register.
5 | Frequency Overload/Underflow | 32 | Only reported as event. Returns "0". Read the Event Register.
6-7 | Not Used | Not Used | "0" is returned.
8 | Calibration Corrupt | 256 | At least one calibration constant is corrupt.
9 | Resistance Overload | 512 | Only reported as event. Returns "0". Read the Event Register.
10 | Capacitance Overload/Underflow | 1024 | Only reported as event. Returns "0". Read the Event Register.
11 | Lower Limit Failed | 2048 | Reading is less than lower limit in limit test.
12 | Upper Limit Failed | 4096 | Reading is greater than upper limit in limit test.
13-15 | Not used | Not Used | "0" is returned.

  • A Factory Reset (*RST command) will clear all bits in the condition register.

Return Format

The command reads the condition register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register (see table above). For example, if bit 12 (decimal value = 4096) is set, this command will return "+4096".

Example

The following command reads the condition register (bit 12 is set).

STAT:QUES:COND?

Typical Response: +4096

See Also

STATus:QUEStionable:ENABle

STATus:QUEStionable[:EVENt]?


STATus:QUEStionable:ENABle

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:QUEStionable:ENABle <enable_value>

STATus:QUEStionable:ENABle?

Description

This command enables bits in the enable register for the Questionable Data Register group. The selected bits are then reported to the Status Byte.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Parameters

Name | Type | Range of Values | Default Value
<enable_value> | Numeric | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | This is a required parameter

Remarks

  • The following table lists the bit definitions for the Questionable Data Register.

Bit Number |  | Decimal Value | Definition
0 | Voltage Overload | 1 | Range overload on DC or AC volts.
1 | Current Overload | 2 | Range overload on DC or AC current.
2-3 | Not Used | Not Used | "0" is returned.
4 | Temperature Overload | 16 | Range overload on temperature.
5 | Frequency Overload/Underflow | 32 | Range overload or underflow on frequency.
6-7 | Not Used | Not Used | "0" is returned.
8 | Calibration Corrupt | 256 | At least one calibration constant is corrupt.
9 | Resistance Overload | 512 | Range overload on resistance.
10 | Capacitance Overload/Underflow | 1024 | Range overload or underflow on capacitance.
11 | Lower Limit Failed | 2048 | Reading is less than lower limit in limit test.
12 | Upper Limit Failed | 4096 | Reading is greater than upper limit in limit test.
13-15 | Not Used | Not Used | "0" is returned.

  • Use the <enable_value> parameter to specify which bits will be reported to the Status Byte. The decimal value specified corresponds to the binary-weighted sum of the bits you wish to enable in the register. For example, to enable bit 0 (decimal value = 1), bit 1 (decimal value = 2), and bit 12 (decimal value = 4096), the corresponding decimal value would be 4099 (1 + 2 + 4096).

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

  • The STATus:PRESet command will clear all bits in the enable register.

  • The *RST command has no effect on this register.

  • The *PSC command affects whether this register is cleared at power on.

Return Format

The query command reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 0 (decimal value = 1) and bit 1 (decimal value = 2) are enabled, the query command will return "+3".

Examples

The following command enables bit 9 (decimal value = 512) in the enable register.

STAT:QUES:ENAB 512

The following query returns which bits are enabled in the register.

STAT:QUES:ENAB?

Typical Response: +512

See Also

STATus:QUEStionable:CONDition?

STATus:QUEStionable[:EVENt]?

STATus:PRESet


STATus:QUEStionable[:EVENt]?

Syntax | Description | Remarks | Return Format | Example

Syntax

STATus:QUEStionable[:EVENt]?

Description

This command queries the event register for the Questionable Data Register group. This is a read-only register and the bits are cleared when you read the register.

For more information on the SCPI Status System for the Keysight 34450A, see the Status System Diagram.

Remarks

  • The following table lists the bit definitions for the Questionable Data Register.

Bit Number |  | Decimal Value | Definition
0 | Voltage Overload | 1 | Range overload on DC or AC volts.
1 | Current Overload | 2 | Range overload on DC or AC current.
2-3 | Not Used | Not Used | "0" is returned.
4 | Temperature Overload | 16 | Range overload on temperature.
5 | Frequency Overload/Underflow | 32 | Range overload or underflow on frequency.
6-7 | Not Used | Not Used | "0" is returned.
8 | Calibration Corrupt | 256 | At least one calibration constant is corrupt.
9 | Resistance Overload | 512 | Range overload resistance.
10 | Capacitance Overload/Underflow | 1024 | Range overload or underflow on capacitance.
11 | Lower Limit Failed | 2048 | Reading is less than lower limit in limit test.
12 | Upper Limit Failed | 4096 | Reading is greater than upper limit in limit test.
13-15 | Not used | Not Used | "0" is returned.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

  • The *RST, STATus:PRESet, and *PSC commands have no effect on this register.

Return Format

The command reads the event register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register. For example, if bit 1 (decimal value = 2) and bit 9 (decimal value = 512) are set, this command will return "+514".

Example

The following command reads the event register (bit 10 is set).

STAT:QUES?

Typical Response: +1024

See Also

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle?


SYSTem Subsystem Introduction

Command Summary

General Commands

SYStem:BEEPer:STATe

SYStem:BEEPer:STATe?

SYSTem:BEEPer[:IMMediate]

SYSTem:ERRor?

SYSTem:PRESet

SYSTem:LFRequency

SYStem:COMMunicate:ENABle

SYSTem:COMMunicate:ENABle?

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess?

SYSTem:LANGuage

SYSTem:LANGuage?

SYSTem:VERSion?


SYSTem:BEEPer:STATe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:BEEPer:STATe <mode>

SYSTem:BEEPer:STATe?

Description

This command disables or enables the beeper tone. The factory default is ON.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter

Remarks

  • Turning off the beeper does not disable the key click generated when you press a front-panel key.

  • A beep tone is always emitted (even with the beep state turned OFF) in the following cases:

    • An error is generated.

    • The continuity threshold is exceeded.

    • A SYST:BEEP command is sent.

  • A beep tone is emitted only if the beep state is ON in the following cases:

    • A set LO or HI limit is exceeded in a limit test.

    • A stable reading is captures in the reading hold mode.

    • A forward-biased diode is measured in the diode test function.

  • The beeper setting is stored in non-volatile memory, and does not change when power has been off or after a Factory Reset (*RST command).

Return Format

The query command returns "0" (OFF) or "1" (ON).

Examples

The following command disables the beeper state.

SYST:BEEP:STAT OFF

The following query returns the beeper state.

SYST:BEEP:STAT?

Typical Response: 0

See Also

SYSTem:BEEPer[:IMMediate]


SYSTem:BEEPer[:IMMediate]

Syntax | Description | Remarks | Example

Syntax

SYSTem:BEEPer[:IMMediate]

Description

This command issues a single beep immediately from the instrument. This may be useful for program development and troubleshooting.

Remarks

  • This command overrides the current beeper state (see SYSTem:BEEPer:STATe command). This means that you can issue a single beep even if the beeper is turned off.

Example

The following command issues a single beep from the instrument.

SYST:BEEP

See Also

SYSTem:BEEPer:STATe


SYSTem:BEEPer:STATe

SYSTem:COMMunicate:ENABle

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:COMMunicate:ENABle <mode>, <interface>

SYSTem:COMMunicate:ENABle? <interface>

Description

This command disables or enables the USB, RS232, or GPIB remote interface.

Parameters

Name | Type | Range of Values | Default Value
<mode> | Boolean | {OFF|0|ON|1} | This is a required parameter
<interface> | Discrete | {USB|RS232|GPIB} | This is a required parameter

Remarks

The interface setting is stored in non-volatile memory, and does not change when power has been off, after a Factory Reset (*RST command), or after an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns "0" (OFF) or "1" (ON) for the specified interface.

Examples

The following command enables USB connectivity.

SYSTem:COMMunicate:ENABle ON, USB


SYSTem:BEEPer:STATe

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess <address>

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess?

Description

This command assigns the instrument's GPIB (IEEE-488) address. Each device on the GPIB interface must have a unique address.

Parameters

Name | Type | Range of Values | Default Value
<address> | Numeric | An integral value between 0 and 30 | This is a required parameter

Remarks

  • Factory GPIB address setting is 22.

  • Your computer's GPIB interface card has its own address. Be sure to avoid using the computer's address for any instrument on the interface bus.

  • The GPIB address is stored in non-volatile memory, and does not change when power has been off, after a Factory Reset (*RST command), or after an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the GPIB address in the form "+22".

Examples

The following command sets the GPIB address.

SYSTem:COMMunicate:GPIB:ADDRess 15

The following query returns the GPIB address currently being used by the instrument.

SYSTem:COMMunicate:GPIB:ADDRess?

Typical Response: +15

See Also

SYSTem:COMMunicate:ENABle


SYSTem:ERRor?

Syntax | Description | Remarks | Return Format | Example

Syntax

SYSTem:ERRor?

Description

This command reads and clears one error from the instrument's error queue. A record of up to 20 errors can be stored in the instrument's error queue. For a complete listing of the Keysight 34450A's error messages, see SCPI Error Messages.

Remarks

  • The instrument beeps once each time a command syntax or hardware error is generated.

  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored.

  • Errors are cleared as you read them.

  • If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".

  • Error conditions are also summarized in the Status Byte Register. For more information on the SCPI Status System for the Keysight 34450A, see Status System Introduction.

  • The error queue is cleared by the *CLS (Clear Status) command (for the I/O session), and when power is cycled (for all errors). All errors are cleared when you read the error queue. However, the error queue is not cleared by a Factory Reset (*RST command).

Return Format

The command reads and clears one error string from the error queue. The error string may contain up to 255 characters and consists of an error number and an error string enclosed in double quotes. For example:

-113,"Undefined header"

Example

The following query reads and clears one error.

SYST:ERR?

Typical Response: -101,"Invalid character"

See Also

*CLS

*SRE


SYSTem:BEEPer:STATe

SYSTem:LANGuage

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:LANGuage <language>

SYSTem:LANGuage?

Description

This command provides a code compatibility switch, which allows you to select the Fluke 45/Fluke 8808 code compatibility mode. In this mode, the 34450A instrument emulates the remote commands for the Fluke 45/Fluke 8808.

Parameters

Name | Type | Range of Values | Default Value
<language> | Discrete | {L1|L2} L1 = Normal mode L2 = Fluke 45/Fluke 8808 code compatibility mode | This is a required parameter

Remarks

  • Following the language switch, the instrument issues a Factory Reset (*RST command).

  • The interface setting is stored in non-volatile memory, and does not change when power has been off, after a Factory Reset (*RST command), or after an Instrument Preset (SYSTem:PRESet command).

  • In Fluke 45/Fluke 8808 code compatibility mode, LANGUAGE {L1|L2} is used for mode switching.

Return Format

The query command returns an ASCII string enclosed in double quotes: "L1", "L2".

Examples

The following command selects the Normal mode.

SYSTem:LANGuage L1

The following command selects the Fluke 45/8808A code compatibility mode.

SYSTem:LANGuage L2


SYSTem:BEEPer:STATe

SYSTem:LFRequency

Syntax | Description | Remarks | Return Format

Syntax

SYSTem:LFRequency {50|60}

SYSTem:LFRequency?

Description

This command sets the line frequency with a 20 ms delay.

Remarks

  • The default value is 50

Return Format

The query command returns "50" (for 50 Hz) or "60" (for 60 Hz) indicating the present reference frequency setting.


SYSTem:PRESet

Syntax | Description | Remarks | Example

Syntax

SYSTem:PRESet

Description

This command is included for compatibility with other products and performs the same actions as the *RST command. See Factory Reset State for a complete listing of the instrument's Factory configuration.

Remarks

  • This command does not affect any previously-stored instrument states (see *SAV command).

Example

The following command resets the instrument.

SYSTem:PRESet


SYSTem:VERSion?

Syntax | Description | Return Format | Example

Syntax

SYSTem:VERSion?

Description

This command returns the version of the SCPI (Standard Commands for Programmable Instruments) standard with which the instrument is in compliance. The instrument complies with the rules and conventions of the indicated version of the SCPI standard.

You cannot query the SCPI version from the front panel.

Return Format

The command returns a string in the form "YYYY.V", where "YYYY" represents the year of the version and "V" represents a version for that year (e.g., 1997.0).

Example

The following query returns the SCPI version.

SYST:VERS?

Typical Response: 1997.0

See Also

Introduction to SCPI Language


TRIGger Subsystem Introduction

Refer to Triggering the Multimeter for an explanation of local and remote triggering capabilities.

Command Summary

TRIGger:SOURce

TRIGger:DELay


Triggering the Multimeter

From the front panel (Local mode), the multimeter always auto–triggers. Auto triggering takes continuous readings at the fastest rate possible for the selected measurement configuration.

From the remote interface, triggering the multimeter is a three–step process:

  1. Configure the multimeter for the measurement by selecting the function, range, resolution, and so on.

  2. Specify the multimeter’s trigger source. Choices are a software (bus) trigger from the remote interface or an immediate internal trigger (default trigger source).

  3. If bus is the trigger source, the measurement is triggered when the *TRG command is executed.

Immediate Triggering

The immediate triggering mode is available from the remote interface only. When you place the multimeter in the wait–for–trigger state (INITiate command), the trigger is issued immediately. This is the default trigger source for remote interface operation. The TRIGger:SOURce IMMediate command selects the immediate trigger source. When the trigger source is immediate, the measurement will be made upon execution of the INITiate, READ? or MEAS? command.

The CONFigure and MEASure? commands automatically set the trigger source to IMMediate.

Software (Bus) Triggering

  • The bus trigger mode is available from the remote interface only. The TRIGger:SOURce BUS command selects the bus trigger source.

  • The bus trigger mode is initiated by sending a bus trigger command (*TRG), after selecting BUS as the trigger source.

  • A MEASure? command overwrites the BUS trigger (sets it to IMMediate) and triggers the DMM and returns a measurement.

  • A CONFigure command overwrites the BUS trigger (sets it to IMMediate).

  • The READ? command does not overwrite the BUS trigger, and if selected, generates an error. It will only trigger the instrument and return a measurement when the IMMediate trigger is selected.

  • The INITiate command only initiates the measurement and needs a trigger (BUS or IMMediate) to make the actual measurement.

MEASure? Examples

The MEAS? command is the easiest way to trigger a measurement and return the reading. For example, the following command triggers a measurement for the present measurement function, range, and resolution, and sends the reading to the output buffer.

MEAS?

You can specify the measurement function, range, and resolution withe the MEAS? command. For example:

MEAS:RES? 1000,3.0e-05

BUS Triggering Example

The following command selects the bus (software) trigger source. Note that the *TRG command will not be accepted unless the instrument is in the "wait-for-trigger" state (INIT command).

TRIG:SOUR BUS
INIT
*TRG
FETC?

Note: Attempting to use the READ? command with BUS triggering, generates an error.

CONFigure + INITiate + FETCH? Example

The following program segment shows how to use the FETCh? command with the CONFigure and INITiate commands. CONFigure sets the trigger source to immediate. The INITiate command places the instrument in the "wait-for-trigger" state. Since the trigger source is immediate, the measurement is made following execution of the INIT command. The FETCh? command retrieves the reading from the instrument's output buffer.

CONF:VOLT:DC 10,3.0e-05
INIT
FETC?

CONFigure + READ? Example

The following program segment shows how to use the READ? command with the CONFigure command. CONFigure sets the trigger source to immediate. Sending the READ? command is similar to sending the INITiate command followed immediately by the FETCh? command. Since the trigger source is immediate, the measurement is made following execution of the READ? command.

CONF:VOLT:DC 10,3.0e-05
READ?

Immediate Trigger + READ? Example

The following program segment shows how to use the READ? command with the IMMediate trigger source. Sending the READ? command is similar to sending the INITiate command followed immediately by the FETCh? command. Since the trigger source is immediate, the measurement is made following execution of the READ? command.

TRIG:SOUR IMM
READ?


MEMory:STATe:RECall:AUTO

TRIGger:DELay

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DELay {<seconds>|MIN|MAX|DEF}

TRIGger:DELay? [{MIN|MAX}]

Description

This command sets the delay between the trigger signal and the first measurement.

Parameters

Name | Type | Range of Values | Default Value
<seconds> | Numeric | 0 to 3600 seconds MIN = 0 seconds DEF = 0 seconds MAX = 3600 seconds | This is a required parameter.

Remarks

  • Trigger delay does not change after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

This command returns the trigger delay in seconds.

Examples

The following command sets a 2-second trigger delay.

TRIGger:DELay 2

The following query returns the trigger delay selected.

TRIGger:DELay?

Typical Response: +2.00000000E+00

See Also

TRIGger:SOURce


TRIGger:SOURce

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:SOURce <source>

TRIGger:SOURce?

Description

This command selects the trigger source for measurements. The instrument will accept a software (bus) command, an immediate (continuous) trigger or an external TTL trigger pulse.

Parameters

Name | Type | Range of Values | Default Value
<source> | Discrete | {IMMediate|BUS|EXTernal} | This is a required parameter.

Remarks

  • After selecting the trigger source, you must place the instrument in the "wait-for-trigger" state using the INITiate command. A trigger will not be accepted from the selected trigger source until the instrument is in the "wait-for-trigger" state. The INITiate command only initiates the measurement and needs a trigger (BUS, IMMediate, or EXTernal) to make the actual measurement.

  • For the IMMediate (continuous) source, the trigger signal is always present. When you place the instrument in the "wait-for-trigger" state, the trigger is issued immediately.

  • For the BUS (software) source, the instrument is triggered by the *TRG command received over the remote interface. The *TRG command will not be accepted unless the multimeter is in the "wait-for-trigger" state.

  • For the EXTernal source, the instrument will accept a hardware trigger applied to the rear-panel Ext Trig Input connector. The instrument takes one reading, each time a TTL pulse (low-true for slope = negative) is received. If the instrument receives an external trigger before it is ready to accept one, it will ignore the trigger.

  • A CONFigure or MEASure? command overwrites the BUS trigger and sets the trigger source to IMMediate.

  • The READ? command does not overwrite the BUS trigger, and if selected, generates an error. It will only trigger the instrument and return a measurement when the IMMediate trigger is selected or an EXTernal signal is detected.

  • The instrument selects the IMMediate trigger source after a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

Return Format

The query command returns the present trigger source: "IMM", "BUS", or "EXT".

Examples

The following command selects the bus (software) trigger source. Note that the *TRG command will not be accepted unless the instrument is in the "wait-for-trigger" state (INIT command).

TRIG:SOUR BUS
INIT
*TRG
FETC?

The following query returns the trigger source currently selected.

TRIG:SOUR?

Typical Response: IMM

See Also

Triggering the Multimeter

*TRG


Commands A-Z

A – E | F – L | M – O | P – S | T – Z

A

ABORt

C

*CLS

CALibration[:ALL]?

CALibration:COUNt?

CALibration:FLAT?

CALibration:SECure:CODE

CALibration:SECure:STATe

CALibration:SECure:STATe?

CALibration:STRing

CALibration:STRing?

CALibration:VALue

CALibration:VALue?

CALibration:STORe

CALCulate:[STATe]

CALCulate:[STATe]?

CALCulate:AVERage:AVERage?

CALCulate:AVERage:COUNt?

CALCulate:AVERage:MAXimum?

CALCulate:AVERage:MINimum?

CALCulate:DB:REFerence

CALCulate:DB:REFerence?

CALCulate:DBM:REFerence

CALCulate:DBM:REFerence?

CALCulate:FUNCtion

CALCulate:FUNCtion?

CALCulate:LIMit:LOWer

CALCulate:LIMit:LOWer?

CALCulate:LIMit:UPPer

CALCulate:LIMit:UPPer?

CALCulate:NULL:OFFSet

CALCulate:NULL:OFFSet?

CONFigure[:PRIMary]?

CONFigure[:PRIMary][:VOLTage]:AC

CONFigure[:PRIMary][:VOLTage][:DC]

CONFigure[:PRIMary]:CAPacitance

CONFigure[:PRIMary]:CONTinuity

CONFigure[:PRIMary]:CURRent:AC

CONFigure[:PRIMary]:CURRent[:DC]

CONFigure[:PRIMary]:DIODe

CONFigure[:PRIMary]:FREQuency

CONFigure[:PRIMary]:FRESistance

CONFigure[:PRIMary]:RESistance

CONFigure[:PRIMary]:TEMPerature

CONFigure:SECondary?

CONFigure:SECondary[:VOLTage]:AC

CONFigure:SECondary[:VOLTage][:DC]

CONFigure:SECondary:CURRent:AC

CONFigure:SECondary:CURRent[:DC]

CONFigure:SECondary:FREQuency

D

DATA:DATA? NVMEM

DATA:DELete NVMEM

DATA:LAST?

DATA:POINts? NVMEM

DISPlay[:WINDow1][:STATe]

DISPlay[:WINDow1][:STATe]?

DISPlay:WINDow2[:STATe]

DISPlay:WINDow2[:STATe]?

E

*ESE

*ESE?

*ESR?

F

FETCh?

FORMat_OUTPut

I

*IDN?

INITiate[:IMMediate]

M

MEASure[:PRIMary][:VOLTage]:AC?

MEASure[:PRIMary][:VOLTage][:DC]?

MEASure[:PRIMary]:CAPacitance?

MEASure[:PRIMary]:CONTinuity?

MEASure[:PRIMary]:CURRent:AC?

MEASure[:PRIMary]:CURRent[:DC]?

MEASure[:PRIMary]:DIODe?

MEASure[:PRIMary]:FREQuency?

MEASure[:PRIMary]:RESistance?

MEASure[:PRIMary]:FRESistance?

MEASure[:PRIMary]:TEMPerature?

MEASure:SECondary[:VOLTage][:DC]?

MEASure:SECondary[:VOLTage]:AC?

MEASure:SECondary:CURRent:AC?

MEASure:SECondary:CURRent[:DC]?

MEASure:SECondary:FREQuency?

MEMory:STATe:RECall:AUTO

MEMory:STATe:RECall:AUTO?

MEMory:STATe:STORe

MEMory:STATe:STORe?

O

*OPC

*OPC?

P

*PSC

*PSC?

R

*RCL

*RST

READ?

S

*SAV

*SRE

*SRE?

*STB?

SAMPle:TIMer

SAMPle:TIMer?

[SENSe:][PRIMary:]VOLTage:AC:RANGe

[SENSe:][PRIMary:]VOLTage:AC:RANGe?

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage:AC:RESolution

[SENSe:][PRIMary:]VOLTage:AC:RESolution?

[SENSe:]SECondary:VOLTage:AC:RANGe

[SENSe:]SECondary:VOLTage:AC:RANGe?

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO?

[SENSe:]SECondary:VOLTage:AC:RESolution

[SENSe:]SECondary:VOLTage:AC:RESolution?

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO?

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe?

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution?

[SENSe:] SECondary:VOLTage[:DC]:IMPedance:AUTO

[SENSe:] SECondary:VOLTage[:DC]:IMPedance:AUTO?

[SENSe:]SECondary:VOLTage[:DC]:RANGe

[SENSe:]SECondary:VOLTage[:DC]:RANGe?

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO?

[SENSe:]SECondary:VOLTage[:DC]:RESolution

[SENSe:]SECondary:VOLTage[:DC]:RESolution?

[SENSe:][PRIMary:]CURRent:AC:RANGe

[SENSe:][PRIMary:]CURRent:AC:RANGe?

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent:AC:RESolution

[SENSe:][PRIMary:]CURRent:AC:RESolution?

[SENSe:]SECondary:CURRent:AC:RANGe

[SENSe:]SECondary:CURRent:AC:RANGe?

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO?

[SENSe:]SECondary:CURRent:AC:RESolution

[SENSe:]SECondary:CURRent:AC:RESolution?

[SENSe:][PRIMary:]CURRent[:DC]:RANGe

[SENSe:][PRIMary:]CURRent[:DC]:RANGe?

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent[:DC]:RESolution

[SENSe:][PRIMary:]CURRent[:DC]:RESolution?

[SENSe:]SECondary:CURRent[:DC]:RANGe

[SENSe:]SECondary:CURRent[:DC]:RANGe?

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO?

[SENSe:]SECondary:CURRent[:DC]:RESolution

[SENSe:]SECondary:CURRent[:DC]:RESolution?

[SENSe:][PRIMary:]RESistance:OCOMpensated

[SENSe:][PRIMary:]RESistance:OCOMpensated?

[SENSe:][PRIMary:]RESistance:RANGe

[SENSe:][PRIMary:]RESistance:RANGe?

[SENSe:][PRIMary:]RESistance:RANGe:AUTO

[SENSe:][PRIMary:]RESistance:RANGe:AUTO?

[SENSe:][PRIMary:]RESistance:RESolution

[SENSe:][PRIMary:]RESistance:RESolution?

[SENSe:][PRIMary:]FRESistance:OCOMpensated

[SENSe:][PRIMary:]FRESistance:OCOMpensated?

[SENSe:][PRIMary:]FRESistance:RANGe

[SENSe:][PRIMary:]FRESistance:RANGe?

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO?

[SENSe:][PRIMary:]FRESistance:RESolution

[SENSe:][PRIMary:]FRESistance:RESolution?

[SENSe:][PRIMary:]FREQuency:APERture

[SENSe:][PRIMary:]FREQuency:APERture?

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe?

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO?

[SENSe:]SECondary:FREQuency:APERture

[SENSe:]SECondary:FREQuency:APERture?

[SENSe:] SECondary: FREQuency:CURRent:RANGe

[SENSe:] SECondary: FREQuency:CURRent:RANGe

[SENSe:] SECondary: FREQuency:CURRent:RANGe:AUTO

[SENSe:] SECondary: FREQuency:CURRent:RANGe:AUTO

[SENSe:]SECondary:FREQuency:VOLTage:RANGe

[SENSe:]SECondary:FREQuency:VOLTage:RANGe?

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO?

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE?

[SENSe:][PRIMary:]CAPacitance:RANGe

[SENSe:][PRIMary:]CAPacitance:RANGe?

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO?

[SENSe:][PRIMary:]FUNCtion

[SENSe:][PRIMary:]FUNCtion?

[SENSe:]SECondary:FUNCtion

[SENSe:]SECondary:FUNCtion?

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

SYStem:BEEPer:STATe

SYStem:BEEPer:STATe?

SYSTem:BEEPer[:IMMediate]

SYSTem:COMMunicate:ENABle

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

SYSTem:ERRor?

SYSTem:LANGuage

SYSTem:LFRrequency

SYSTem:PRESet

SYSTem:VERSion?

T

*TRG

*TST?

TRIGger:SOURce

TRIGger:SOURce?

TRIGger:DELay

TRIGger:DELay?

W

*WAI


Command Quick Reference

Keysight 34450A Command Quick Reference

Syntax Conventions

  • Braces ( { } ) enclose the parameter choices for a given command string. The braces are not sent with the command string.

  • A vertical bar ( | ) separates multiple parameter choices for a given command string. The bar is not sent with the command string.

  • Triangle brackets ( < > ) indicate that you must specify a value for the enclosed parameter. For example, the above syntax statement shows the <range> parameter enclosed in triangle brackets. The brackets are not sent with the command string. You must specify a value for the parameter (e.g., "VOLT:DC:RANG 10").

  • Some parameters are enclosed in square brackets ( [ ] ). The square brackets indicate that the parameter is optional and can be omitted. The brackets are not sent with the command string. If you do not specify a value for an optional parameter, the instrument chooses a default value.

Measurement Commands

MEASure[:PRIMary][:VOLTage]:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure[:PRIMary][:VOLTage][:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure[:PRIMary]:CAPacitance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]CONTinuity?

MEASure:[PRIMary:]CURRent:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]CURRent[:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]DIODe?

MEASure:[PRIMary:]FREQuency? [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]FRESistance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]RESistance? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:[PRIMary:]TEMPerature? [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]

MEASure:SECondary[:VOLTage][:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:SECondary[:VOLTage]:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:SECondary:CURRent:AC? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:SECondary:CURRent[:DC]? [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

MEASure:SECondary:FREQuency? [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

Temperature Configuration Commands

CONFigure[PRIMary]:TEMPerature [{<probe_type>|DEF}[,{<type>|DEF} [,1 [,{<resolution>|MIN|MAX|DEF}]]]]
CONFigure[:PRIMary]?

UNIT:TEMPerature <units>
UNIT:TEMPerature?

Thermistor Configuration

[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE <type>
[SENSe:][PRIMary:]TEMPerature:TRANsducer:THERmistor:TYPE?

[SENSe:][PRIMary:]FUNCtion "TEMPerature"

[SENSe:][PRIMary:]FUNCtion?

Voltage Configuration Commands

DC Voltage Configuration

CONFigure[:PRIMary][:VOLTage][:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure:SECondary[:VOLTage][:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure[:PRIMary]?

CONFigure:SECondary?

[SENSe:][PRIMary:]FUNCtion "VOLTage[:DC]"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]VOLTage[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage[:DC]:RESolution? [{MIN|MAX}]

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]VOLTage[:DC]:IMPedance:AUTO?

[SENSe:]SECondary:FUNCtion "VOLTage[:DC]"

[SENSe:]SECondary:FUNCtion?

[SENSe:]SECondary:VOLTage[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage[:DC]:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:VOLTage[:DC]:RANGe:AUTO?

[SENSe:]SECondary:VOLTage[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage[:DC]:RESolution? [{MIN|MAX}]

[SENSe:]SECondary:VOLTage[:DC]:IMPedance:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:VOLTage[:DC]:IMPedance:AUTO?

AC Voltage Configuration

CONFigure[:PRIMary][:VOLTage]:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure:SECondary[:VOLTage]:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure[:PRIMary]?

CONFigure:SECondary?

[SENSe:][PRIMary:]FUNCtion "VOLTage:AC"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]VOLTage:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage:AC:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]VOLTage:AC:RANGe:AUTO?

[SENSe:][PRIMary:]VOLTage:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]VOLTage:AC:RESolution? [{MIN|MAX}]

[SENSe:]SECondary:FUNCtion "VOLTage:AC"

[SENSe:]SECondary:FUNCtion?

[SENSe:]SECondary:VOLTage:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage:AC:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:VOLTage:AC:RANGe:AUTO?

[SENSe:]SECondary:VOLTage:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:VOLTage:AC:RESolution?

Resistance Configuration Commands

CONFigure[:PRIMary]:RESistance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]
CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "RESistance"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]RESistance:OCOMpensated {<mode>|OFF|0|ON|1}

[SENSe:][PRIMary:]RESistance:OCOMpensated?

[SENSe:][PRIMary:]RESistance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]RESistance:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]RESistance:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]RESistance:RANGe:AUTO?

[SENSe:][PRIMary:]RESistance:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]RESistance:RESolution? [{MIN|MAX}]

CONFigure[:PRIMary]:FRESistance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "FRESistance"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]FRESistance:OCOMpensated {<mode>|OFF|0|ON|1}

[SENSe:][PRIMary:]FRESistance:OCOMpensated?

[SENSe:][PRIMary:]FRESistance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FRESistance:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]FRESistance:RANGe:AUTO?

[SENSe:][PRIMary:]FRESistance:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FRESistance:RESolution? [{MIN|MAX}]

Current Configuration Commands

DC Current Configuration

CONFigure[:PRIMary]:CURRent[:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]
CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "CURRent[:DC]"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]CURRent[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent[:DC]:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]CURRent[:DC]:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent[:DC]:RESolution? [{MIN|MAX}]

CONFigure:SECondary:CURRent[:DC] [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure:SECondary?

[SENSe:]SECondary:FUNCtion "CURRent[:DC]"

[SENSe:]SECondary:FUNCtion?

[SENSe:]SECondary:CURRent[:DC]:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent[:DC]:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:CURRent[:DC]:RANGe:AUTO?

[SENSe:]SECondary:CURRent[:DC]:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent[:DC]:RESolution? [{MIN|MAX}]

AC Current Configuration

CONFigure[:PRIMary]:CURRent:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]
CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "CURRent:AC"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]CURRent:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent:AC:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]CURRent:AC:RANGe:AUTO?

[SENSe:][PRIMary:]CURRent:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CURRent:AC:RESolution? [{MIN|MAX}]

CONFigure:SECondary:CURRent:AC [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure:SECondary?

[SENSe:]SECondary:FUNCtion "CURRent:AC"

[SENSe:]SECondary:FUNCtion?

[SENSe:]SECondary:CURRent:AC:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent:AC:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:CURRent:AC:RANGe:AUTO?

[SENSe:]SECondary:CURRent:AC:RESolution {<resolution>|MIN|MAX|DEF}

[SENSe:]SECondary:CURRent:AC:RESolution? [{MIN|MAX}]

Capacitance Configuration Commands

CONFigure:CAPacitance [{<range>|AUTO|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "CAPacitance"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]CAPacitance:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]CAPacitance:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]CAPacitance:RANGe:AUTO?

Continuity and Diode Configuration Commands

CONFigure[:PRIMary]:CONTinuity

CONFigure[:PRIMary]?

CONFigure[:PRIMary]:DIODe

CONFigure[:PRIMary]?

Frequency Configuration Commands

Frequency Configuration

CONFigure[:PRIMary]:FREQuency [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]
CONFigure[:PRIMary]?

[SENSe:][PRIMary:]FUNCtion "FREQuency"

[SENSe:][PRIMary:]FUNCtion?

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]FREQuency:VOLTage:RANGe:AUTO?

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe {<range>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe? [{MIN|MAX}]

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO {OFF|0|ON|1}

[SENSe:][PRIMary:]FREQuency:CURRent:RANGe:AUTO?

[SENSe:][PRIMary:]FREQuency:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:][PRIMary:]FREQuency:APERture? [{MIN|MAX}]

CONFigure:SECondary:FREQuency [{<range>|MIN|MAX|DEF} [,{<resolution>|MIN|MAX|DEF}]]

CONFigure:SECondary?

[SENSe:]SECondary:FUNCtion "FREQuency"

[SENSe:]SECondary:FUNCtion?

[SENSe:]SECondary:FREQuency:VOLTage:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:VOLTage:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:FREQuency:VOLTage:RANGe:AUTO?

[SENSe:]SECondary:FREQuency:CURRent:RANGe {<range>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:CURRent:RANGe? [{MIN|MAX}]

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO {OFF|0|ON|1}

[SENSe:]SECondary:FREQuency:CURRent:RANGe:AUTO?

[SENSe:]SECondary:FREQuency:APERture {<seconds>|MIN|MAX|DEF}

[SENSe:]SECondary:FREQuency:APERture? [{MIN|MAX}]

Measurement Configuration Commands

ABORt

INITiate[:IMMediate]

READ?

TRIGger:SOURce {<source>|IMMediate|BUS|EXTernal}
TRIGger:SOURce?

Triggering Commands

*TRG

INITiate[:IMMediate]

READ?

TRIGger:SOURce {<source>|IMMediate|BUS|EXTernal}
TRIGger:SOURce?

TRIGger:DELay {<seconds>|MIN|MAX|DEF}

TRIGger:DELay? [{MIN|MAX}]

Calculation (Math) Commands

CALCulate:AVERage:AVERage?
CALCulate:AVERage:COUNt?
CALCulate:AVERage:MAXimum?
CALCulate:AVERage:MINimum?

CALCulate:DB:REFerence {<value>|MIN|MAX}
CALCulate:DB:REFerence? {MIN|MAX}

CALCulate:DBM:REFerence {<value>|MIN|MAX}
CALCulate:DBM:REFerence? {MIN|MAX}

CALCulate:FUNCtion {NULL|DB|DBM|AVERage|LIMit|HOLD}
CALCulate:FUNCtion?

CALCulate:LIMit:LOWer {<value>|MIN|MAX}
CALCulate:LIMit:LOWer? {MIN|MAX}

CALCulate:LIMit:UPPer {<value>|MIN|MAX}
CALCulate:LIMit:UPPer? {MIN|MAX}

CALCulate:NULL:OFFSet {<value>|MIN |MAX}
CALCulate:NULL:OFFSet? {MIN|MAX}

CALCulate[:STATe] {OFF|ON}
CALCulate[:STATe]?

Reading Memory Commands

FETCh?

Calibration Commands

CALibration[:ALL]?
CALibration:COUNt?

CALibration:SECure:CODE <new_code>
CALibration:SECure:STATe {OFF|0|ON|1|RESET}, <code>
CALibration:SECure:STATe?

CALibration:STRing "<string>"
CALibration:STRing?

CALibration:VALue <value>
CALibration:VALue?

CALibration:STORe

CALibration:FLAT?

State Storage Commands

*RCL {0|1|2|3|4|5}

*SAV {0|1|2|3|4|5}

MEMory:STATe:RECall:AUTO {OFF|0|ON|1}
MEMory:STATe:RECall:AUTO?

MEMory:STATe:STORe {OFF|0|ON|1}
MEMory:STATe:STORe?

IEEE-488 Commands

*CLS

*ESE <enable_value>
*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*PSC {0|1}
*PSC?

*RST

*SRE <enable_value>
*SRE?

*STB?

*TRG

*TST?

*WAI

System-Related Commands

DISPlay[:WINDow1][:STATe] <mode>

DISPlay[:WINDow1][:STATe]?

DISPlay:WINDow2[:STATe] <mode>

DISPlay:WINDow2[:STATe]?

SYSTem:BEEPer[:IMMediate]
SYSTem:BEEPer:STATe {OFF|0|ON|1}
SYSTem:BEEPer:STATe?

SYSTem:ERRor?

SYSTem:PRESet

SYSTem:VERSion?

SYSTem:LFRequency {50|60}

SYSTem:LFRequency?

SYSTem:COMMunicate:ENABle <mode> {OFF|0|ON|1}, <interface> {USB| RS232| GPIB}

SYSTem:COMMunicate:ENABle? <interface> {USB|RS232|GPIB}

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess <address>

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess?

SYSTem:LANGuage <language> {L1|L2}

SYSTem:LANGuage?

Status System Commands

STATus:OPERation:CONDition?
STATus:OPERation:ENABle <enable_value>
STATus:OPERation:ENABle?
STATus:OPERation[:EVENt]?

STATus:PRESet

STATus:QUEStionable:CONDition?
STATus:QUEStionable:ENABle <enable_value>
STATus:QUEStionable:ENABle?
STATus:QUEStionable[:EVENt]?

SAMPle:TIMer {<interval>|MIN|MAX}

SAMPle:TIMer?

DATA:DATA? NVMEM

DATA:DELete NVMEM

DATA:LAST?

DATA:POINts? NVMEM

FORMat:OUTPut {1,2}

FORMat:OUTPut?

Copyright © 2012–2015 Keysight Technologies


Error Messages

SCPI Error Messages

Command Errors | Execution Errors | Internal Errors | Query Errors |Self-Test Errors | Calibration Errors

The Keysight 34450A returns error messages in accordance with the SCPI standard.

  • A record of up to 20 errors can be stored in the instrument's error queue. If more than 20 errors have occurred, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".

  • The instrument beeps once each time a command syntax or hardware error is generated.

  • A special global error queue holds all power-on and hardware-related errors (for example, over-temperature).

  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored. Once you have read all of the interface-specific errors, the errors in the global error queue are retrieved.

  • Errors are cleared as you read them.

  • Error conditions are also summarized in the Status Byte Register. For more information on the SCPI Status System for the Keysight 34450A, see Status Subsystem Introduction.

  • The interface-specific error queues are cleared by the *CLS (Clear Status) command and when power is cycled. All errors are cleared when you read the error queue. The error queue is not cleared by a Factory Reset (*RST command).

To Read Errors:

SYSTem:ERRor? Read and clear one error from the queue

Errors have the following format (the error string may contain up to 80 characters):

-113,"Undefined header"

Command Errors

0 | No error
-100 | Command error
-101 | Invalid character
-102 | Syntax error
-103 | Invalid separator
-104 | Data type error
-105 | GET not allowed
-108 | Parameter not allowed
-109 | Missing parameter
-110 | Command header error
-111 | Header separator error
-112 | Program mnemonic too long
-113 | Undefined header
-114 | Header suffix out of range
-120 | Numeric data error
-121 | Invalid character in number
-123 | Exponent too large
-124 | Too many digits
-128 | Numeric data not allowed
-130 | Suffix error
-131 | Invalid suffix
-134 | Suffix too long
-138 | Suffix not allowed
-140 | Character data error
-141 | Invalid character data
-144 | Character data too long
-148 | Character data not allowed
-150 | String data error
-151 | Invalid string data
-158 | String data not allowed
-160 | Block data error
-161 | Invalid block data
-168 | Block data not allowed
-170 | Expression error
-171 | Invalid expression
-178 | Expression data not allowed
-180 | Macro error
-181 | Invalid outside macro definition
-183 | Invalid inside macro definition
-184 | Macro parameter error

Execution Errors

-200 | Execution error
-211 | Trigger ignored
-213 | Init ignored
-221 | Settings conflict
-222 | Data out of range
-223 | Too much data
-224 | Illegal parameter value
-225 | Out of memory
-230 | Data corrupt or stale
-241 | Hardware missing
-270 | Macro error
-272 | Macro execution error
-273 | Illegal macro label
-276 | Macro recursion error
-277 | Macro redefinition not allowed

Internal Errors

–310 | System error
–330 | Self-test failed
–350 | Queue overflow

Query Errors

-400 | Query error
-410 | Query INTERRUPTED
-420 | Query UNTERMINATED
-430 | Query DEADLOCKED
-440 | Query UNTERMINATED after indefinite response
531 | Memory store is disabled
532 | Cannot achieve requested resolution
540 | Cannot use overload as math reference

Self-Test Errors

The 34450A self-test (see the *TST? command) performs a series of tests on the instrument hardware. Any failure of these tests will generate a SCPI error number -330, with additional test failure information. Refer to the Keysight 34450A Service Guide for more information.

The form of this error message is as follows:

-330,"Self-test failed; <test# - testname>"

Where test# is the number of the test that failed (range 600 - 622) and testname describes the test. Here is an example of a test failure message:

-330,"Self-test failed; 630 - Unstable Oscillator"

The following is the list of test numbers and descriptions:

600 | I/O processor failed self test
601 | M/B eeprom failed
602 | M/B flash failed
603 | M/B ASIC failed
604 | DC low path zero test failed
605 | DC high path zero test failed
606 | AC path zero test failed
607 | GPIB board failed

Calibration Errors

The following errors indicate failures that may occur during a calibration. Refer to the Keysight 34450A Service Guide for more information.

702 | Calibration secured
703 | Invalid secure code
704 | Secure code too long
708 | Unable to store calibration data
709 | No calibration for this function
720 | DCV calibration failed
721 | DCI calibration failed
722 | RES calibration failed
723 | CAP calibration failed
724 | FRES calibration failed
725 | FREQ calibration failed
726 | ACV calibration failed
727 | ACI calibration failed
732 | ACV flatness calibration failed


Power-On and Reset State

The following tables show the factory defaults for various instrument settings. The parameters marked with a bullet (•) are stored in non-volatile memory, and are not affected by power-on or a system reset. Other parameters are stored in volatile memory and are reset to the indicated values at power-on or after a *RST command is issued.

The power-on/reset state will be different than that in the table if you have enabled the power-on state recall mode. This mode is entered from the Utility menu. See the Keysight 34450A User's and Service Guide for further information.

Parameter

Factory Setting

Power-on / Reset State

Measurement Configuration

Function

DCV

DCV

Secondary Function | OFF | OFF

Range

AUTO

AUTO

Resolution

5 ½ digits

5 ½ digits

Temperature Units

°C

User setting

Offset Compensation (OHM) | OFF | OFF
Hi-Z (DCV) | 10M | 10M

Math Operations

Math State, Function

Off, Null

Off, Null

dBm Reference Resistance

600 Ω

User setting

Statistic Display

Single

Single

Trigger Operations

* Trigger Source

Auto Trigger

Auto Trigger

System-Related Operations

Power-Down Recall

Disabled

User Setting

Stored States

0-5 cleared

No Change

Beeper

On

User Setting

Display

On

On

Display Brightness | Full | User Setting

* Remote/ Local State

Local

Local

* Keyboard

Unlocked, Local key enabled

Unlocked, Local key enabled

* Reading Output Buffer

Cleared

Cleared

* Error Queue

Cleared

Cleared

* Power-on Status Clear

Enabled

User Setting

* Status Registers, Masks and Transition Filters

Cleared

Cleared if power-on status clear enabled; no change otherwise

Serial Number

Unique value per-instrument

No Change

Calibration

Calibration state

Secured

User Setting

Calibration value

0

No Change

Language

Language Mode

L1 (Normal mode)

User Setting

IO Configuration

Enable Interface
GPIB | Disabled | User Setting
RS232 | Disabled | User Setting

USB

Enabled

User Setting

GPIB Setting

GPIB Address

22

User Setting

RS232 Setting

  • Baud Rate: 9600

  • Stop Bit: 1

  • Parity: None

User Setting

* State managed by IO Processor firmware

The Error Queue is cleared at power on. However, it is not cleared by a *RST command.


CONFigure?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CONFigure?

Description

This command returns the present instrument configuration as a quoted string.

Remarks

  • The *RST command will set all measurement parameters to their factory settings, clear reading memory, and clear all stored statistical data.

Return Format

The command returns a series of comma-separated fields indicating the present function, range, and resolution. The short form of the function name is always returned (e.g., "CURR:AC", "FREQ", etc.).

Example

The following query returns the present configuration of the instrument (the quotes are also returned).

CONF?

Typical Response: "VOLT +1.000000E+01,+3.000000E-06"

See Also

CONFigure


Definite-Length Block Data

Definite-length block response data allows any type of device-dependent data to be transmitted as a series of 8-bit binary data bytes. This is particularly useful for transferring large quantities of data or 8-bit extended ASCII codes.


New Line

Line Terminator

<NL> = New Line or Line Feed (ASCII decimal 10)


Non-Volatile Memory

Information in memory is not lost when power is turned off.


Quoted String

Quoted ASCII String

A quoted ASCII string is a string delimited either by " or '. This quoted string must be received by the instrument. Some programming languages require may special handling or syntax.


Volatile Memory

Information in memory is lost when power is turned off.


Condition Register

A condition register continuously monitors the state of the instrument. The bits in the condition register are updated in real time and the bits are not latched or buffered.


Enable Register

An enable register defines which bits in the event register will be reported to the Status Byte register group. You can write to or read from an enable register.


Event Register

An event register latches the various events from the condition register. There is no buffering in this register; while an event bit is set, subsequent events corresponding to that bit are ignored. This is a read-only register.


thermistor_5k

5 kΩ (YSI 44007 Series)